Skip to content

← Actionable
Critical, CVSS 9.9

Incus has an abitrary file write through its systemd-creds options

CVE-2026-33945GHSA-q4q8-7f2j-9h9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/lxc/incus/v6 6.23.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-33945: 0.46% estimated exploitation activity in the next 30 days; percentile 39.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Incus instances have an option to provide credentials to systemd in the guest. For containers, this is handled through a shared directory. An attacker can use the name of a systemd credential to escape that directory and overwrite arbitrary files on the host system. This can in turn be used to perform local privilege escalation or cause a DoS. Details An attacker can set a configuration key named something like systemd.credential.../../../../../../root/.bashrc to cause Incus to write outside of the credentials directory associated with the container. This makes use of the fact that the Incus syntax for such credentials is systemd.credential.XYZ where XYZ can itself contain more periods. While it's not possible to read any data this way, it's possible to write to arbitrary files as root, enabling both privilege escalation and denial of service attacks. Credit This issue was discovered and reported by the team at 7asecurity

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q4q8-7f2j-9h9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33945

Advisory: Incus has an abitrary file write through its systemd-creds options
IDs: CVE-2026-33945, GHSA-q4q8-7f2j-9h9f
Record: https://patchnext.com/advisories/cve-2026-33945 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/lxc/incus/v6 6.23.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/lxc/incus/v6: affected < 6.23.0; fixed in 6.23.0

## Suggested inspection (read-only)
- Go github.com/lxc/incus/v6: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/lxc/incus/v6.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q4q8-7f2j-9h9f (GitHub-reviewed advisory GHSA-q4q8-7f2j-9h9f lists affected ranges: Go github.com/lxc/incus/v6 >=0 <6.23.0)

Commands are suggestions: review each one before running it.

Loading voting…