Skip to content

← Actionable
High, CVSS 8.2amended

Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options

CVE-2026-33941GHSA-xjpj-3mr7-gcpf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (handlebars 4.7.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm handlebars

    Affected
    >= 4.0.0, <= 4.7.8
    Fixed in
    4.7.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-33941: 0.30% estimated exploitation activity in the next 30 days; percentile 22.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Handlebars CLI precompiler (bin/handlebars / lib/precompiler.js) concatenates user-controlled strings — template file names and several CLI options — directly into the JavaScript it emits, without any escaping or sanitization. An attacker who can influence template filenames or CLI arguments can inject arbitrary JavaScript that executes when the generated bundle is loaded in Node.js or a browser. Description lib/precompiler.js generates JavaScript source by string-interpolating several values directly into the output. Four distinct injection points exist: 1. Template name injection template.name is derived from the file system path. A filename containing " or ']; breaks out of the string literal and injects arbitrary JavaScript. 2. Namespace injection (-n / --namespace) opts.namespace is emitted as raw JavaScript. Anything after a ; in the value becomes an additional JavaScript statement. 3. CommonJS path injection (-c / --commonjs) opts.commonjs is interpolated inside…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xjpj-3mr7-gcpf

  2. Revision 1 · created ·

    Published from osv record GHSA-xjpj-3mr7-gcpf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33941

Advisory: Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options
IDs: CVE-2026-33941, GHSA-xjpj-3mr7-gcpf
Record: https://patchnext.com/advisories/cve-2026-33941 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: handlebars 4.7.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm handlebars: affected >= 4.0.0, <= 4.7.8; fixed in 4.7.9

## Suggested inspection (read-only)
- `npm ls handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on handlebars.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xjpj-3mr7-gcpf (OSV record GHSA-xjpj-3mr7-gcpf lists affected ranges: npm handlebars >=4.0.0 <4.7.9 (fixed))
- Verified: https://github.com/advisories/GHSA-xjpj-3mr7-gcpf (GitHub-reviewed advisory GHSA-xjpj-3mr7-gcpf lists affected ranges: npm handlebars >=4.0.0 <=4.7.8)

Commands are suggestions: review each one before running it.

Loading voting…