Skip to content

← Actionable
High, CVSS 8.1amended

Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block

CVE-2026-33938GHSA-3mfm-83xf-c92r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (handlebars 4.7.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm handlebars

    Affected
    >= 4.0.0, <= 4.7.8
    Fixed in
    4.7.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-33938: 0.72% estimated exploitation activity in the next 30 days; percentile 54.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The @partial-block special variable is stored in the template data context and is reachable and mutable from within a template via helpers that accept arbitrary objects. When a helper overwrites @partial-block with a crafted Handlebars AST, a subsequent invocation of {{ @partial-block}} compiles and executes that AST, enabling arbitrary JavaScript execution on the server. Description Handlebars stores @partial-block in the data frame that is accessible to templates. In nested contexts, a parent frame's @partial-block is reachable as @parent.partial-block. Because the data frame is a mutable object, any registered helper that accepts an object reference and assigns properties to it can overwrite @partial-block with an attacker-controlled value. When {{ @partial-block}} is subsequently evaluated, invokePartial receives the crafted object. The runtime, finding an object that is not a compiled function, falls back to dynamically compiling the value via env.compile(). If that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3mfm-83xf-c92r

  2. Revision 1 · created ·

    Published from osv record GHSA-3mfm-83xf-c92r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33938

Advisory: Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block
IDs: CVE-2026-33938, GHSA-3mfm-83xf-c92r
Record: https://patchnext.com/advisories/cve-2026-33938 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: handlebars 4.7.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm handlebars: affected >= 4.0.0, <= 4.7.8; fixed in 4.7.9

## Suggested inspection (read-only)
- `npm ls handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on handlebars.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3mfm-83xf-c92r (OSV record GHSA-3mfm-83xf-c92r lists affected ranges: npm handlebars >=4.0.0 <4.7.9 (fixed))
- Verified: https://github.com/advisories/GHSA-3mfm-83xf-c92r (GitHub-reviewed advisory GHSA-3mfm-83xf-c92r lists affected ranges: npm handlebars >=4.0.0 <=4.7.8)

Commands are suggestions: review each one before running it.

Loading voting…