Handlebars.js has JavaScript Injection via AST Type Confusion
CVE-2026-33937GHSA-2w6w-674q-4c4q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (handlebars 4.7.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm handlebars
- Affected
- >= 4.0.0, <= 4.7.8
- Fixed in
- 4.7.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2w6w-674q-4c4q lists affected ranges: npm handlebars >=4.0.0 <=4.7.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2w6w-674q-4c4q lists affected ranges: npm handlebars >=4.0.0 <4.7.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33937: 1.91% estimated exploitation activity in the next 30 days; percentile 79.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Handlebars.compile() accepts a pre-parsed AST object in addition to a template string. The value field of a NumberLiteral AST node is emitted directly into the generated JavaScript without quoting or sanitization. An attacker who can supply a crafted AST to compile() can therefore inject and execute arbitrary JavaScript, leading to Remote Code Execution on the server. Description Handlebars.compile() accepts either a template string or a pre-parsed AST. When an AST is supplied, the JavaScript code generator in lib/handlebars/compiler/javascript-compiler.js emits NumberLiteral values verbatim: Because the value is not wrapped in quotes or otherwise sanitized, passing a string such as {},{})) + process.getBuiltinModule('childprocess').execFileSync('id').toString() // as the value of a NumberLiteral causes the generated eval-ed code to break out of its intended context and execute arbitrary commands. Any endpoint that deserializes user-controlled JSON and passes the result…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2w6w-674q-4c4q
- Revision 2 · amended ·
Amended from osv record GHSA-2w6w-674q-4c4q
- Revision 1 · created ·
Published from ghsa record GHSA-2w6w-674q-4c4q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33937 Advisory: Handlebars.js has JavaScript Injection via AST Type Confusion IDs: CVE-2026-33937, GHSA-2w6w-674q-4c4q Record: https://patchnext.com/advisories/cve-2026-33937 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: handlebars 4.7.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm handlebars: affected >= 4.0.0, <= 4.7.8; fixed in 4.7.9 ## Suggested inspection (read-only) - `npm ls handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on handlebars. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2w6w-674q-4c4q (GitHub-reviewed advisory GHSA-2w6w-674q-4c4q lists affected ranges: npm handlebars >=4.0.0 <=4.7.8) - Verified: https://osv.dev/vulnerability/GHSA-2w6w-674q-4c4q (OSV record GHSA-2w6w-674q-4c4q lists affected ranges: npm handlebars >=4.0.0 <4.7.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…