python-ecdsa: Denial of Service via improper DER length validation in crafted private keys
CVE-2026-33936GHSA-9f5j-8jwj-x28g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ecdsa 0.19.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ecdsa
- Affected
- < 0.19.2
- Fixed in
- 0.19.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9f5j-8jwj-x28g lists affected ranges: PyPI ecdsa >=0 <0.19.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9f5j-8jwj-x28g lists affected ranges: PyPI ecdsa >=0 <0.19.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-33936: 0.48% estimated exploitation activity in the next 30 days; percentile 41.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An issue in the low-level DER parsing functions can cause unexpected exceptions to be raised from the public API functions. 1. ecdsa.der.removeoctetstring() accepts truncated DER where the encoded length exceeds the available buffer. For example, an OCTET STRING that declares a length of 4096 bytes but provides only 3 bytes is parsed successfully instead of being rejected. 2. Because of that, a crafted DER input can cause SigningKey.fromder() to raise an internal exception (IndexError: index out of bounds on dimension 1) rather than cleanly rejecting malformed DER (e.g., raising UnexpectedDER or ValueError). Applications that parse untrusted DER private keys may crash if they do not handle unexpected exceptions, resulting in a denial of service. Impact Potential denial-of-service when parsing untrusted DER private keys due to unexpected internal exceptions, and malformed DER acceptance due to missing bounds checks in DER helper functions. Reproduction Attach and run the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9f5j-8jwj-x28g
- Revision 1 · created ·
Published from osv record GHSA-9f5j-8jwj-x28g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33936 Advisory: python-ecdsa: Denial of Service via improper DER length validation in crafted private keys IDs: CVE-2026-33936, GHSA-9f5j-8jwj-x28g Record: https://patchnext.com/advisories/cve-2026-33936 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ecdsa 0.19.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ecdsa: affected < 0.19.2; fixed in 0.19.2 ## Suggested inspection (read-only) - `python -m pip show ecdsa`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ecdsa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9f5j-8jwj-x28g (OSV record GHSA-9f5j-8jwj-x28g lists affected ranges: PyPI ecdsa >=0 <0.19.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9f5j-8jwj-x28g (GitHub-reviewed advisory GHSA-9f5j-8jwj-x28g lists affected ranges: PyPI ecdsa >=0 <0.19.2) Commands are suggestions: review each one before running it.
Loading voting…