Skip to content

← Actionable
Medium, CVSS 5.9

ImageMagick has a heap overflow caused by integer overflow/wraparound in viff encoder on 32-bit builds

CVE-2026-33900GHSA-v67w-737x-v2c9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (magick.net-q8-x86 14.12.0; magick.net-q16-hdri-anycpu 14.12.0; magick.net-q16-anycpu 14.12.0; magick.net-q16-hdri-x86 14.12.0; magick.net-q16-x86 14.12.0; 1 more package under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-33900: 0.43% estimated exploitation activity in the next 30 days; percentile 37.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below both 7.1.2-19 and 6.9.13-44, the viff encoder contains an integer truncation/wraparound issue on 32-bit builds that could trigger an out of bounds heap write, potentially causing a crash. This issue has been fixed in versions 6.9.13-44 and 7.1.2-19.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v67w-737x-v2c9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33900

Advisory: ImageMagick has a heap overflow caused by integer overflow/wraparound in viff encoder on 32-bit builds
IDs: CVE-2026-33900, GHSA-v67w-737x-v2c9
Record: https://patchnext.com/advisories/cve-2026-33900 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: magick.net-q8-x86 14.12.0; magick.net-q16-hdri-anycpu 14.12.0; magick.net-q16-anycpu 14.12.0; magick.net-q16-hdri-x86 14.12.0; magick.net-q16-x86 14.12.0; magick.net-q8-anycpu 14.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet magick.net-q8-x86: affected < 14.12.0; fixed in 14.12.0
- NuGet magick.net-q16-hdri-anycpu: affected < 14.12.0; fixed in 14.12.0
- NuGet magick.net-q16-anycpu: affected < 14.12.0; fixed in 14.12.0
- NuGet magick.net-q16-hdri-x86: affected < 14.12.0; fixed in 14.12.0
- NuGet magick.net-q16-x86: affected < 14.12.0; fixed in 14.12.0
- NuGet magick.net-q8-anycpu: affected < 14.12.0; fixed in 14.12.0

## Suggested inspection (read-only)
- NuGet magick.net-q8-x86: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-x86: check the installed version with your package manager.
- NuGet magick.net-q16-x86: check the installed version with your package manager.
- NuGet magick.net-q8-anycpu: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magick.net-q8-x86, magick.net-q16-hdri-anycpu, magick.net-q16-anycpu, magick.net-q16-hdri-x86, magick.net-q16-x86, magick.net-q8-anycpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v67w-737x-v2c9 (GitHub-reviewed advisory GHSA-v67w-737x-v2c9 lists affected ranges: NuGet magick.net-q16-anycpu >=0 =0 =0 =0 =0 =0 <14.12.0)

Commands are suggestions: review each one before running it.

Loading voting…