Skip to content

← Actionable
High, CVSS 8.8

Local Incus UI web server vulnerable to nuthentication bypass

CVE-2026-33898GHSA-453r-g2pg-cxxq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/lxc/incus/v6/cmd/incus 6.23.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-33898: 0.35% estimated exploitation activity in the next 30 days; percentile 29.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The web server spawned by incus webui incorrectly validates the authentication token such that an invalid value will be accepted. Details incus webui runs a local web server on a random localhost port. For authentication, it provides the user with a URL containing an authentication token. When accessed with that token, Incus creates a cookie persisting that token without needing to include it in subsequent HTTP requests. While the Incus client correctly validates the value of the cookie, it does not correctly validate the token when passed int the URL. This allows for an attacker able to locate and talk to the temporary web server on localhost to have as much access to Incus as the user who ran incus webui. This can lead to privilege escalation by another local user or an access to the user's Incus instances and possibly system resources by a remote attack able to trick the local user into interacting with the Incus UI web server. Credit This issue was discovered and reported…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-453r-g2pg-cxxq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33898

Advisory: Local Incus UI web server vulnerable to nuthentication bypass
IDs: CVE-2026-33898, GHSA-453r-g2pg-cxxq
Record: https://patchnext.com/advisories/cve-2026-33898 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/lxc/incus/v6/cmd/incus 6.23.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/lxc/incus/v6/cmd/incus: affected < 6.23.0; fixed in 6.23.0

## Suggested inspection (read-only)
- Go github.com/lxc/incus/v6/cmd/incus: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/lxc/incus/v6/cmd/incus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-453r-g2pg-cxxq (GitHub-reviewed advisory GHSA-453r-g2pg-cxxq lists affected ranges: Go github.com/lxc/incus/v6/cmd/incus >=0 <6.23.0)

Commands are suggestions: review each one before running it.

Loading voting…