Forge has signature forgery in Ed25519 due to missing S > L check
CVE-2026-33895GHSA-q67f-28xg-22rw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-forge 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm node-forge
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q67f-28xg-22rw lists affected ranges: npm node-forge >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q67f-28xg-22rw lists affected ranges: npm node-forge >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-33895: 0.53% estimated exploitation activity in the next 30 days; percentile 44.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Ed25519 signature verification accepts forged non-canonical signatures where the scalar S is not reduced modulo the group order (S = L). A valid signature and its S + L variant both verify in forge, while Node.js crypto.verify (OpenSSL-backed) rejects the S + L variant, as defined by the specification. This class of signature malleability has been exploited in practice to bypass authentication and authorization logic (see CVE-2026-25793, CVE-2022-35961). Applications relying on signature uniqueness (i.e., dedup by signature bytes, replay tracking, signed-object canonicalization checks) may be bypassed. Impacted Deployments Tested commit: 8e1d527fe8ec2670499068db783172d4fb9012e5 Affected versions: tested on v1.3.3 (latest release) and all versions since Ed25519 was implemented. Configuration assumptions: - Default forge Ed25519 verify API path (ed25519.verify(...)). Root Cause In lib/ed25519.js, cryptosignopen(...) uses the signature's last 32 bytes (S) directly in scalar…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q67f-28xg-22rw
- Revision 1 · created ·
Published from osv record GHSA-q67f-28xg-22rw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33895 Advisory: Forge has signature forgery in Ed25519 due to missing S > L check IDs: CVE-2026-33895, GHSA-q67f-28xg-22rw Record: https://patchnext.com/advisories/cve-2026-33895 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-forge 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-forge: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `npm ls node-forge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-forge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q67f-28xg-22rw (OSV record GHSA-q67f-28xg-22rw lists affected ranges: npm node-forge >=0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q67f-28xg-22rw (GitHub-reviewed advisory GHSA-q67f-28xg-22rw lists affected ranges: npm node-forge >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…