Skip to content

← Actionable
High, CVSS 7.5amended

Forge has Denial of Service via Infinite Loop in BigInteger.modInverse() with Zero Input

CVE-2026-33891GHSA-5m6q-g25r-mvwx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-forge 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-33891: 0.61% estimated exploitation activity in the next 30 days; percentile 49.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Denial of Service (DoS) vulnerability exists in the node-forge library due to an infinite loop in the BigInteger.modInverse() function (inherited from the bundled jsbn library). When modInverse() is called with a zero value as input, the internal Extended Euclidean Algorithm enters an unreachable exit condition, causing the process to hang indefinitely and consume 100% CPU. Affected Package Package name: node-forge (npm: node-forge) Repository: https://github.com/digitalbazaar/forge Affected versions: All versions (including latest) Affected file: lib/jsbn.js, function bnModInverse() Root cause component: Bundled copy of the jsbn (JavaScript Big Number) library Vulnerability Details Type: Denial of Service (DoS) CWE: CWE-835 (Loop with Unreachable Exit Condition) Attack vector: Network (if the application processes untrusted input that reaches modInverse) Privileges required: None User interaction: None Impact: Availability (process hangs indefinitely) Suggested CVSS v3.1…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5m6q-g25r-mvwx

  2. Revision 1 · created ·

    Published from osv record GHSA-5m6q-g25r-mvwx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33891

Advisory: Forge has Denial of Service via Infinite Loop in BigInteger.modInverse() with Zero Input
IDs: CVE-2026-33891, GHSA-5m6q-g25r-mvwx
Record: https://patchnext.com/advisories/cve-2026-33891 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-forge 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm node-forge: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `npm ls node-forge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-forge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5m6q-g25r-mvwx (OSV record GHSA-5m6q-g25r-mvwx lists affected ranges: npm node-forge >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5m6q-g25r-mvwx (GitHub-reviewed advisory GHSA-5m6q-g25r-mvwx lists affected ranges: npm node-forge >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…