Skip to content

← Actionable
Medium, CVSS 5.4amended

ApostropheCMS: Stored XSS via CSS Custom Property Injection in @apostrophecms/color-field Escaping Style Tag Context

CVE-2026-33889GHSA-97v6-998m-fp4g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.29.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-33889: 0.22% estimated exploitation activity in the next 30 days; percentile 12.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The @apostrophecms/color-field module bypasses color validation for values prefixed with -- (intended for CSS custom properties), but performs no HTML sanitization on these values. When styles containing attacker-controlled color values are rendered into <style tags — both in the global stylesheet (editors only) and in per-widget style elements (all visitors) — the lack of escaping allows an editor to inject </style followed by arbitrary HTML/JavaScript, achieving stored XSS against all site visitors. Details Root Cause 1: Validation bypass in color field (modules/@apostrophecms/color-field/index.js:36) The color field's convert method uses TinyColor to validate color values, but exempts any value starting with --: A value like --x: red}</style<scriptalert(document.cookie)</script<style passes validation because it starts with --. The launder.string() call performs type coercion only — it does not strip HTML metacharacters like <, , or /. Root Cause 2a: Unescaped rendering in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-97v6-998m-fp4g

  2. Revision 1 · created ·

    Published from osv record GHSA-97v6-998m-fp4g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33889

Advisory: ApostropheCMS: Stored XSS via CSS Custom Property Injection in @apostrophecms/color-field Escaping Style Tag Context
IDs: CVE-2026-33889, GHSA-97v6-998m-fp4g
Record: https://patchnext.com/advisories/cve-2026-33889 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.29.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apostrophe: affected < 4.29.0; fixed in 4.29.0

## Suggested inspection (read-only)
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-97v6-998m-fp4g (OSV record GHSA-97v6-998m-fp4g lists affected ranges: npm apostrophe >=0 <4.29.0 (fixed))
- Verified: https://github.com/advisories/GHSA-97v6-998m-fp4g (GitHub-reviewed advisory GHSA-97v6-998m-fp4g lists affected ranges: npm apostrophe >=0 <4.29.0)

Commands are suggestions: review each one before running it.

Loading voting…