ApostropheCMS: publicApiProjection Bypass via project Query Builder in Piece-Type REST API
CVE-2026-33888GHSA-xhq9-58fw-859p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.29.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm apostrophe
- Affected
- < 4.29.0
- Fixed in
- 4.29.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xhq9-58fw-859p lists affected ranges: npm apostrophe >=0 <4.29.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xhq9-58fw-859p lists affected ranges: npm apostrophe >=0 <4.29.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-33888: 0.51% estimated exploitation activity in the next 30 days; percentile 43.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The getRestQuery method in the @apostrophecms/piece-type module checks whether a MongoDB projection has already been set before applying the admin-configured publicApiProjection. An unauthenticated attacker can supply a project query parameter in the REST API request to pre-populate the projection state, causing the security-enforced publicApiProjection to be skipped entirely. This allows disclosure of fields that the site administrator explicitly restricted from public access. Details When an unauthenticated user queries the piece-type REST API, the getRestQuery method processes the request at modules/@apostrophecms/piece-type/index.js:1120: At [1], applyBuildersSafely iterates over all query string parameters and invokes their corresponding builder methods. The project builder exists in @apostrophecms/doc-type with a launder method (doc-type/index.js:1876) that sanitizes values to booleans: When a request includes ?project[someField]=1, the builder sets query.state.project…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xhq9-58fw-859p
- Revision 1 · created ·
Published from osv record GHSA-xhq9-58fw-859p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33888 Advisory: ApostropheCMS: publicApiProjection Bypass via project Query Builder in Piece-Type REST API IDs: CVE-2026-33888, GHSA-xhq9-58fw-859p Record: https://patchnext.com/advisories/cve-2026-33888 (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.29.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm apostrophe: affected < 4.29.0; fixed in 4.29.0 ## Suggested inspection (read-only) - `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apostrophe. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xhq9-58fw-859p (OSV record GHSA-xhq9-58fw-859p lists affected ranges: npm apostrophe >=0 <4.29.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xhq9-58fw-859p (GitHub-reviewed advisory GHSA-xhq9-58fw-859p lists affected ranges: npm apostrophe >=0 <4.29.0) Commands are suggestions: review each one before running it.
Loading voting…