Skip to content

← Actionable
Critical, CVSS 9.3amended

Langflow has Authenticated Code Execution in Agentic Assistant Validation

CVE-2026-33873GHSA-v8hw-mh8c-jxfc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    <= 1.8.1
    Fixed in
    1.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-33873: 1.45% estimated exploitation activity in the next 30 days; percentile 73.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description 1. Summary The Agentic Assistant feature in Langflow executes LLM-generated Python code during its validation phase. Although this phase appears intended to validate generated component code, the implementation reaches dynamic execution sinks and instantiates the generated class server-side. In deployments where an attacker can access the Agentic Assistant feature and influence the model output, this can result in arbitrary server-side Python execution. 2. Description 2.1 Intended Functionality The Agentic Assistant endpoints are designed to help users generate and validate components for a flow. Users can submit requests to the assistant, which returns candidate component code for further processing. A reasonable security expectation is that validation should treat model output as untrusted text and perform only static or side-effect-free checks. The externally reachable endpoints are:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-v8hw-mh8c-jxfc

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-v8hw-mh8c-jxfc

  4. Revision 1 · created ·

    Published from ghsa record GHSA-v8hw-mh8c-jxfc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33873

Advisory: Langflow has Authenticated Code Execution in Agentic Assistant Validation
IDs: CVE-2026-33873, GHSA-v8hw-mh8c-jxfc
Record: https://patchnext.com/advisories/cve-2026-33873 (revision 4, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected <= 1.8.1; fixed in 1.9.0

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v8hw-mh8c-jxfc (GitHub-reviewed advisory GHSA-v8hw-mh8c-jxfc lists affected ranges: PyPI langflow >=0 <=1.8.1)
- Verified: https://osv.dev/vulnerability/GHSA-v8hw-mh8c-jxfc (OSV record GHSA-v8hw-mh8c-jxfc lists affected ranges: PyPI langflow >=0 <1.9.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…