Convict has Prototype Pollution via startsWith() function
CVE-2026-33864GHSA-44fc-8fm5-q62h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (convict 6.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm convict
- Affected
- <= 6.2.4
- Fixed in
- 6.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-44fc-8fm5-q62h lists affected ranges: npm convict >=0 <=6.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-44fc-8fm5-q62h lists affected ranges: npm convict >=0 <6.2.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A prototype pollution vulnerability exists in the latest version of the convict npm package (6.2.4). Despite a previous fix that attempted to mitigate prototype pollution by checking whether user input started with a forbidden key, it is still possible to pollute Object.prototype via a crafted input using String.prototype. Details The vulnerability resides in line 564 of https://github.com/mozilla/node-convict/blob/master/packages/convict/src/main.js where startsWith() function is used to check whether user provided input contain forbidden strings. PoC Steps to reproduce 1. Install latest version of convict using npm install or cloning from git 2. Run the following code snippet: Expected behavior Prototype pollution should be prevented and {} should not gain new properties. This should be printed on the console: Actual behavior Object.prototype is polluted This is printed on the console: Impact This is a prototype pollution vulnerability, which can have severe security…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-44fc-8fm5-q62h
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-44fc-8fm5-q62h
- Revision 1 · created ·
Published from ghsa record GHSA-44fc-8fm5-q62h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33864 Advisory: Convict has Prototype Pollution via startsWith() function IDs: CVE-2026-33864, GHSA-44fc-8fm5-q62h Record: https://patchnext.com/advisories/cve-2026-33864 (revision 4, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: convict 6.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm convict: affected <= 6.2.4; fixed in 6.2.5 ## Suggested inspection (read-only) - `npm ls convict --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on convict. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-44fc-8fm5-q62h (GitHub-reviewed advisory GHSA-44fc-8fm5-q62h lists affected ranges: npm convict >=0 <=6.2.4) - Verified: https://osv.dev/vulnerability/GHSA-44fc-8fm5-q62h (OSV record GHSA-44fc-8fm5-q62h lists affected ranges: npm convict >=0 <6.2.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…