Convict has prototype pollution via load(), loadFile(), and schema initialization
CVE-2026-33863GHSA-hf2r-9gf9-rwch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (convict 6.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm convict
- Affected
- <= 6.2.4
- Fixed in
- 6.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hf2r-9gf9-rwch lists affected ranges: npm convict >=0 <=6.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hf2r-9gf9-rwch lists affected ranges: npm convict >=0 <6.2.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Two unguarded prototype pollution paths exist, not covered by previous fixes: 1. config.load() / config.loadFile() — overlay() recursively merges config data without checking for forbidden keys. Input containing proto or constructor.prototype (e.g. from a JSON file) causes the recursion to reach Object.prototype and write attacker-controlled values onto it. 2. Schema initialization — passing a schema with constructor.prototype. keys to convict({...}) causes default-value propagation to write directly to Object.prototype at startup. Depending on how polluted properties are consumed, impact ranges from unexpected behavior to authentication bypass or RCE. Workarounds Do not pass untrusted data to load(), loadFile(), or convict(). Resources Prior advisory: GHSA-44fc-8fm5-q62h Related issue: https://github.com/mozilla/node-convict/issues/423
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-hf2r-9gf9-rwch
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-hf2r-9gf9-rwch
- Revision 1 · created ·
Published from ghsa record GHSA-hf2r-9gf9-rwch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33863 Advisory: Convict has prototype pollution via load(), loadFile(), and schema initialization IDs: CVE-2026-33863, GHSA-hf2r-9gf9-rwch Record: https://patchnext.com/advisories/cve-2026-33863 (revision 4, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: convict 6.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm convict: affected <= 6.2.4; fixed in 6.2.5 ## Suggested inspection (read-only) - `npm ls convict --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on convict. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hf2r-9gf9-rwch (GitHub-reviewed advisory GHSA-hf2r-9gf9-rwch lists affected ranges: npm convict >=0 <=6.2.4) - Verified: https://osv.dev/vulnerability/GHSA-hf2r-9gf9-rwch (OSV record GHSA-hf2r-9gf9-rwch lists affected ranges: npm convict >=0 <6.2.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…