Skip to content

← Actionable
Critical, CVSS 9.1amended

@fastify/express has a middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)

CVE-2026-33808GHSA-6hw5-45gm-fj88

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/express 4.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33808: 0.48% estimated exploitation activity in the next 30 days; percentile 41.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @fastify/express v4.0.4 fails to normalize URLs before passing them to Express middleware when Fastify router normalization options are enabled. This allows complete bypass of path-scoped authentication middleware via two vectors: 1. Duplicate slashes (//admin/dashboard) when ignoreDuplicateSlashes: true is configured 2. Semicolon delimiters (/admin;bypass) when useSemicolonDelimiter: true is configured In both cases, Fastify's router normalizes the URL and matches the route, but @fastify/express passes the original un-normalized URL to Express middleware, which fails to match and is skipped. Note: This is distinct from GHSA-g6q3-96cp-5r5m (CVE-2026-22037), which addressed URL percent-encoding bypass and was patched in v4.0.3. These normalization gaps remain in v4.0.4. A similar class of normalization issue was addressed in @fastify/middie via GHSA-8p85-9qpw-fwgw (CVE-2026-2880), but @fastify/express does not include the equivalent fixes. Details The vulnerability exists in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-6hw5-45gm-fj88

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-6hw5-45gm-fj88

  4. Revision 1 · created ·

    Published from ghsa record GHSA-6hw5-45gm-fj88

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33808

Advisory: @fastify/express has a middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)
IDs: CVE-2026-33808, GHSA-6hw5-45gm-fj88
Record: https://patchnext.com/advisories/cve-2026-33808 (revision 4, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/express 4.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/express: affected <= 4.0.4; fixed in 4.0.5

## Suggested inspection (read-only)
- `npm ls @fastify/express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/express.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6hw5-45gm-fj88 (GitHub-reviewed advisory GHSA-6hw5-45gm-fj88 lists affected ranges: npm @fastify/express >=0 <=4.0.4)
- Verified: https://osv.dev/vulnerability/GHSA-6hw5-45gm-fj88 (OSV record GHSA-6hw5-45gm-fj88 lists affected ranges: npm @fastify/express >=0 <4.0.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…