Skip to content

← Actionable
High, CVSS 7.4amended

@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

CVE-2026-33804GHSA-v9ww-2j6r-98q6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/middie 9.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-33804: 0.28% estimated exploitation activity in the next 30 days; percentile 20.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact @fastify/middie v9.3.1 and earlier does not read the deprecated (but still functional) top-level ignoreDuplicateSlashes option, only reading from routerOptions. This creates a normalization gap: Fastify's router normalizes duplicate slashes but middie does not, allowing middleware bypass via URLs with duplicate leading slashes (e.g., //admin/secret). This only affects applications using the deprecated top-level configuration style (fastify({ ignoreDuplicateSlashes: true })). Applications using routerOptions: { ignoreDuplicateSlashes: true } are not affected. This is distinct from GHSA-8p85-9qpw-fwgw (CVE-2026-2880), which was patched in v9.2.0. Patches Upgrade to @fastify/middie = 9.3.2. Workarounds Migrate from deprecated top-level ignoreDuplicateSlashes: true to routerOptions: { ignoreDuplicateSlashes: true }.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v9ww-2j6r-98q6

  2. Revision 1 · created ·

    Published from osv record GHSA-v9ww-2j6r-98q6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33804

Advisory: @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
IDs: CVE-2026-33804, GHSA-v9ww-2j6r-98q6
Record: https://patchnext.com/advisories/cve-2026-33804 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/middie 9.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/middie: affected <= 9.3.1; fixed in 9.3.2

## Suggested inspection (read-only)
- `npm ls @fastify/middie --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/middie.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v9ww-2j6r-98q6 (OSV record GHSA-v9ww-2j6r-98q6 lists affected ranges: npm @fastify/middie >=0 <9.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-v9ww-2j6r-98q6 (GitHub-reviewed advisory GHSA-v9ww-2j6r-98q6 lists affected ranges: npm @fastify/middie >=0 <=9.3.1)

Commands are suggestions: review each one before running it.

Loading voting…