Skip to content

← Actionable
Low, CVSS 2.8amended

go-git missing validation decoding Index v4 files leads to panic

CVE-2026-33762GHSA-gm2x-2g9h-ccm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/go-git/go-git/v5 5.17.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-33762: 0.18% estimated exploitation activity in the next 30 days; percentile 7.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact `go-git`’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (`go-git` supports only `v2` and `v3`) are not vulnerable to this issue. An attacker able to supply a crafted `.git/index` file can cause applications using go-git to panic while reading the index. If the application does not recover from panics, this results in process termination, leading to a denial-of-service (DoS) condition. Exploitation requires the ability to modify or inject a Git index file within the local repository in disk. This typically implies write access to the `.git` directory.

Patches Users should upgrade to `v5.17.1`, or the latest `v6` pseudo-version, in order…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-gm2x-2g9h-ccm8

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-gm2x-2g9h-ccm8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gm2x-2g9h-ccm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33762

Advisory: go-git missing validation decoding Index v4 files leads to panic
IDs: CVE-2026-33762, GHSA-gm2x-2g9h-ccm8
Record: https://patchnext.com/advisories/cve-2026-33762 (revision 3, source checked 3 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/go-git/go-git/v5 5.17.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/go-git/go-git/v5: affected < 5.17.1; fixed in 5.17.1

## Suggested inspection (read-only)
- Go github.com/go-git/go-git/v5: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/go-git/go-git/v5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gm2x-2g9h-ccm8 (GitHub-reviewed advisory GHSA-gm2x-2g9h-ccm8 lists affected ranges: Go github.com/go-git/go-git/v5 >=0 <=5.17.0)
- Verified: https://osv.dev/vulnerability/GHSA-gm2x-2g9h-ccm8 (OSV record GHSA-gm2x-2g9h-ccm8 lists affected ranges: Go github.com/go-git/go-git/v5 >=0 <5.17.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…