Skip to content

← Actionable
Medium, CVSS 6.2amended

rfc3161-client Has Improper Certificate Validation

CVE-2026-33753GHSA-3xxc-pwj6-jgrj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rfc3161-client 1.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-33753: 0.19% estimated exploitation activity in the next 30 days; percentile 8.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An Authorization Bypass vulnerability in rfc3161-client's signature verification allows any attacker to impersonate a trusted TimeStamping Authority (TSA). By exploiting a logic flaw in how the library extracts the leaf certificate from an unordered PKCS#7 bag of certificates, an attacker can append a spoofed certificate matching the target commonname and Extended Key Usage (EKU) requirements. This tricks the library into verifying these authorization rules against the forged certificate while validating the cryptographic signature against an actual trusted TSA (such as FreeTSA), thereby bypassing the intended TSA authorization pinning entirely. Details The root cause lies in rfc3161client.verify.Verifier.verifyleafcerts(). The library attempts to locate the leaf certificate within the parsed TimeStampResponse PKCS#7 SignedData bag using a naive algorithm: This loop erroneously assumes that the valid leaf certificate is simply the first certificate in the bag that does not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3xxc-pwj6-jgrj

  2. Revision 1 · created ·

    Published from osv record GHSA-3xxc-pwj6-jgrj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33753

Advisory: rfc3161-client Has Improper Certificate Validation
IDs: CVE-2026-33753, GHSA-3xxc-pwj6-jgrj
Record: https://patchnext.com/advisories/cve-2026-33753 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rfc3161-client 1.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI rfc3161-client: affected <= 1.0.5; fixed in 1.0.6

## Suggested inspection (read-only)
- `python -m pip show rfc3161-client`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rfc3161-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3xxc-pwj6-jgrj (OSV record GHSA-3xxc-pwj6-jgrj lists affected ranges: PyPI rfc3161-client >=0 <1.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-3xxc-pwj6-jgrj (GitHub-reviewed advisory GHSA-3xxc-pwj6-jgrj lists affected ranges: PyPI rfc3161-client >=0 <=1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…