n8n Vulnerable to LDAP Filter Injection in LDAP Node
CVE-2026-33751GHSA-w83q-mcmx-mh42
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.14.1, 2.13.3, 1.123.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.27>= 2.14.0, <= 2.14.0>= 2.0.0-rc.0, < 2.13.3
- Fixed in
- 1.123.27, 2.14.1, 2.13.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w83q-mcmx-mh42 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w83q-mcmx-mh42 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2026-33751: 0.25% estimated exploitation activity in the next 30 days; percentile 16.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A flaw in the LDAP node's filter escape logic allowed LDAP metacharacters to pass through unescaped when user-controlled input was interpolated into LDAP search filters. In workflows where external user input is passed via expressions into the LDAP node's search parameters, an attacker could manipulate the constructed filter to retrieve unintended LDAP records or bypass authentication checks implemented in the workflow. Exploitation requires a specific workflow configuration: - The LDAP node must be used with user-controlled input passed via expressions (e.g., from a form or webhook). Patches The issue has been fixed in n8n versions 1.123.27, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the LDAP node by…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w83q-mcmx-mh42
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w83q-mcmx-mh42
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33751 Advisory: n8n Vulnerable to LDAP Filter Injection in LDAP Node IDs: CVE-2026-33751, GHSA-w83q-mcmx-mh42 Record: https://patchnext.com/advisories/cve-2026-33751 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.14.1, 2.13.3, 1.123.27. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.27; >= 2.14.0, <= 2.14.0; >= 2.0.0-rc.0, < 2.13.3; fixed in 1.123.27, 2.14.1, 2.13.3 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w83q-mcmx-mh42 (OSV record GHSA-w83q-mcmx-mh42 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3 (fixed)) - Verified: https://github.com/advisories/GHSA-w83q-mcmx-mh42 (GitHub-reviewed advisory GHSA-w83q-mcmx-mh42 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3) Commands are suggestions: review each one before running it.
Loading voting…