Skip to content

← Actionable
High, CVSS 7.8amended

BentoML has Dockerfile Command Injection via system_packages in bentofile.yaml

CVE-2026-33744GHSA-jfjg-vc52-wqvf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bentoml 1.4.37), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bentoml

    Affected
    <= 1.4.36
    Fixed in
    1.4.37

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-33744: 0.26% estimated exploitation activity in the next 30 days; percentile 17.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The docker.systempackages field in bentofile.yaml accepts arbitrary strings that are interpolated directly into Dockerfile RUN commands without sanitization. Since systempackages is semantically a list of OS package names (data), users do not expect values to be interpreted as shell commands. A malicious bentofile.yaml achieves arbitrary command execution during bentoml containerize / docker build. Affected Component - src/bentomlsdk/images.py:85-89 — .format(packages=" ".join(packages)) into shell command - src/bentoml/internal/container/frontend/dockerfile/templates/basedebian.j2:13 — {{ optionssystempackages | join(' ') }} - src/bentoml/internal/bento/buildconfig.py:174 — No validation on systempackages - All distro install commands in src/bentoml/internal/container/frontend/dockerfile/init.py Affected Versions All versions supporting docker.systempackages in bentofile.yaml, confirmed on 1.4.36. Steps to Reproduce 1. Create a project directory with: service.py:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jfjg-vc52-wqvf

  2. Revision 1 · created ·

    Published from osv record GHSA-jfjg-vc52-wqvf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33744

Advisory: BentoML has Dockerfile Command Injection via system_packages in bentofile.yaml
IDs: CVE-2026-33744, GHSA-jfjg-vc52-wqvf
Record: https://patchnext.com/advisories/cve-2026-33744 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bentoml 1.4.37. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bentoml: affected <= 1.4.36; fixed in 1.4.37

## Suggested inspection (read-only)
- `python -m pip show bentoml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bentoml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jfjg-vc52-wqvf (OSV record GHSA-jfjg-vc52-wqvf lists affected ranges: PyPI bentoml >=0 <1.4.37 (fixed))
- Verified: https://github.com/advisories/GHSA-jfjg-vc52-wqvf (GitHub-reviewed advisory GHSA-jfjg-vc52-wqvf lists affected ranges: PyPI bentoml >=0 <=1.4.36)

Commands are suggestions: review each one before running it.

Loading voting…