srvx is vulnerable to middleware bypass via absolute URI in request line
CVE-2026-33732GHSA-p36q-q72m-gchr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (srvx 0.11.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm srvx
- Affected
- < 0.11.13
- Fixed in
- 0.11.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p36q-q72m-gchr lists affected ranges: npm srvx >=0 <0.11.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p36q-q72m-gchr lists affected ranges: npm srvx >=0 <0.11.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-33732: 0.26% estimated exploitation activity in the next 30 days; percentile 17.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A pathname parsing discrepancy in srvx's FastURL allows middleware bypass on the Node.js adapter when a raw HTTP request uses an absolute URI with a non-standard scheme (e.g. file://). Details When Node.js receives an absolute URI in the request line (e.g. GET file://hehe?/internal/run HTTP/1.1), req.url is set verbatim to file://hehe?/internal/run. Since this doesn't start with /, NodeRequestURL passes it directly to FastURL as a string, which stores it in #href for lazy manual parsing. FastURL#getPos() locates the pathname by finding :// then scanning for the next / — but this fails for URLs like file://hehe?/internal/run where a ? appears before the first / after the authority. The manual parser extracts pathname as /internal/run, while native URL correctly parses it as pathname / with search ?/internal/run. This discrepancy means the router (using the fast-path) matches /internal/run, but if any middleware triggers a deopt to native URL (e.g. by accessing hostname),…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p36q-q72m-gchr
- Revision 1 · created ·
Published from osv record GHSA-p36q-q72m-gchr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33732 Advisory: srvx is vulnerable to middleware bypass via absolute URI in request line IDs: CVE-2026-33732, GHSA-p36q-q72m-gchr Record: https://patchnext.com/advisories/cve-2026-33732 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: srvx 0.11.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm srvx: affected < 0.11.13; fixed in 0.11.13 ## Suggested inspection (read-only) - `npm ls srvx --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on srvx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p36q-q72m-gchr (OSV record GHSA-p36q-q72m-gchr lists affected ranges: npm srvx >=0 <0.11.13 (fixed)) - Verified: https://github.com/advisories/GHSA-p36q-q72m-gchr (GitHub-reviewed advisory GHSA-p36q-q72m-gchr lists affected ranges: npm srvx >=0 <0.11.13) Commands are suggestions: review each one before running it.
Loading voting…