dd-trace-java: Unsafe deserialization in RMI instrumentation may lead to remote code execution
CVE-2026-33728GHSA-579q-h82j-r5v2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.datadoghq:dd-java-agent 1.60.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.datadoghq:dd-java-agent
- Affected
- >= 0.40.0, < 1.60.3
- Fixed in
- 1.60.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-579q-h82j-r5v2 lists affected ranges: Maven com.datadoghq:dd-java-agent >=0.40.0 <1.60.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33728: 0.71% estimated exploitation activity in the next 30 days; percentile 53.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In versions of dd-trace-java prior to 1.60.3, the RMI instrumentation registered a custom endpoint that deserialized incoming data without applying serialization filters. On JDK version 16 and earlier, an attacker with network access to a JMX or RMI port on an instrumented JVM could exploit this to potentially achieve remote code execution. All three of the following conditions must be true to exploit this vulnerability: 1. dd-trace-java is attached as a Java agent (-javaagent) on Java 16 or earlier 2. A JMX/RMI port has been explicitly configured via -Dcom.sun.management.jmxremote.port and is network-reachable 3. A gadget-chain-compatible library is present on the classpath Impact Arbitrary remote code execution with the privileges of the user running the instrumented JVM. Recommendation - For JDK = 17: No action is required, but upgrading is strongly encouraged. - For JDK = 8u121 < JDK 17: Upgrade to dd-trace-java version 1.60.3 or later. - For JDK < 8u121 and earlier where…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-579q-h82j-r5v2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33728 Advisory: dd-trace-java: Unsafe deserialization in RMI instrumentation may lead to remote code execution IDs: CVE-2026-33728, GHSA-579q-h82j-r5v2 Record: https://patchnext.com/advisories/cve-2026-33728 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.datadoghq:dd-java-agent 1.60.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.datadoghq:dd-java-agent: affected >= 0.40.0, < 1.60.3; fixed in 1.60.3 ## Suggested inspection (read-only) - Maven com.datadoghq:dd-java-agent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.datadoghq:dd-java-agent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-579q-h82j-r5v2 (GitHub-reviewed advisory GHSA-579q-h82j-r5v2 lists affected ranges: Maven com.datadoghq:dd-java-agent >=0.40.0 <1.60.3) Commands are suggestions: review each one before running it.
Loading voting…