Skip to content

← Actionable
High, CVSS 7.3amended

n8n Has External Secrets Authorization Bypass in Credential Saving

CVE-2026-33722GHSA-fxcw-h3qj-8m8p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.6.4, 1.123.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.23>= 2.0.0-rc.0, < 2.6.4
    Fixed in
    1.123.23, 2.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-33722: 0.27% estimated exploitation activity in the next 30 days; percentile 18.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user without permission to list external secrets could reference a secret by the external name in a credential and retrieve its plaintext value when saving the credential. This bypassed the externalSecret:list permission check and allowed access to secrets stored in connected vaults without admin or owner privileges. - This issue requires the instance to have an external secrets vault configured. - The attacker must know or be able to guess the name of a target secret. Patches The issue has been fixed in n8n versions 1.123.23 and 2.6.4. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n access to fully trusted users only. - Disable external secrets integration until the patch can be applied. These workarounds do not fully remediate the risk and should only be used as short-term mitigation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fxcw-h3qj-8m8p

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fxcw-h3qj-8m8p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33722

Advisory: n8n Has External Secrets Authorization Bypass in Credential Saving
IDs: CVE-2026-33722, GHSA-fxcw-h3qj-8m8p
Record: https://patchnext.com/advisories/cve-2026-33722 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.6.4, 1.123.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.23; >= 2.0.0-rc.0, < 2.6.4; fixed in 1.123.23, 2.6.4

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fxcw-h3qj-8m8p (OSV record GHSA-fxcw-h3qj-8m8p lists affected ranges: npm n8n >=0 =2.0.0-rc.0 <2.6.4 (fixed))
- Verified: https://github.com/advisories/GHSA-fxcw-h3qj-8m8p (GitHub-reviewed advisory GHSA-fxcw-h3qj-8m8p lists affected ranges: npm n8n >=0 =2.0.0-rc.0 <2.6.4)

Commands are suggestions: review each one before running it.

Loading voting…