OpenHands is Vulnerable to Command Injection through its Git Diff Handler
CVE-2026-33718GHSA-7h8w-hj9j-8rjw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openhands-ai 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openhands-ai
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7h8w-hj9j-8rjw lists affected ranges: PyPI openhands-ai >=0 <1.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7h8w-hj9j-8rjw lists affected ranges: PyPI openhands-ai >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2026-33718: 2.01% estimated exploitation activity in the next 30 days; percentile 80.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Command Injection vulnerability exists in the getgitdiff() method at openhands/runtime/utils/githandler.py:134. The path parameter from the /api/conversations/{conversationid}/git/diff API endpoint is passed unsanitized to a shell command, allowing authenticated attackers to execute arbitrary commands in the agent sandbox. The user is already allowed to instruct the agent to execute commands, but this bypasses the normal channels. --- Details Vulnerable Code Path The vulnerability flows through these files: 1. API Endpoint (openhands/server/routes/files.py:267-277) 2. Runtime (openhands/runtime/base.py:1231-1233) 3. Vulnerable Method (openhands/runtime/utils/githandler.py:10-12, 134) 4. Shell Execution (openhands/runtime/utils/gitdiff.py:25-27) Root Cause The filepath parameter is directly interpolated into a shell command string using Python's .format() method without any sanitization. When this command is executed with shell=True, shell metacharacters like ", ;, and
are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7h8w-hj9j-8rjw
- Revision 1 · created ·
Published from osv record GHSA-7h8w-hj9j-8rjw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33718 Advisory: OpenHands is Vulnerable to Command Injection through its Git Diff Handler IDs: CVE-2026-33718, GHSA-7h8w-hj9j-8rjw Record: https://patchnext.com/advisories/cve-2026-33718 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openhands-ai 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openhands-ai: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - `python -m pip show openhands-ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openhands-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7h8w-hj9j-8rjw (OSV record GHSA-7h8w-hj9j-8rjw lists affected ranges: PyPI openhands-ai >=0 <1.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7h8w-hj9j-8rjw (GitHub-reviewed advisory GHSA-7h8w-hj9j-8rjw lists affected ranges: PyPI openhands-ai >=0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…