Skip to content

← Actionable
High, CVSS 8.7amended

n8n has SQL Injection in Data Table Node via orderByColumn Expression

CVE-2026-33713GHSA-98c2-4cr3-4jc3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.14.1, 2.13.3, 1.123.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.26>= 2.14.0, <= 2.14.0>= 2.0.0-rc.0, < 2.13.3
    Fixed in
    2.14.1, 2.13.3, 1.123.26

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33713: 0.43% estimated exploitation activity in the next 30 days; percentile 37.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with permission to create or modify workflows could exploit a SQL injection vulnerability in the Data Table Get node. On default SQLite DB, single statements can be manipulated and the attack surface is practically limited. On PostgreSQL deployments, multi-statement execution is possible, enabling data modification and deletion. Patches The issue has been fixed in n8n versions 1.123.26, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Data Table node by adding n8n-nodes-base.dataTable to the NODESEXCLUDE environment variable. - Review existing workflows for Data Table Get nodes where orderByColumn is set to an expression that incorporates external or user-supplied input. These…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-98c2-4cr3-4jc3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-98c2-4cr3-4jc3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33713

Advisory: n8n has SQL Injection in Data Table Node via orderByColumn Expression
IDs: CVE-2026-33713, GHSA-98c2-4cr3-4jc3
Record: https://patchnext.com/advisories/cve-2026-33713 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.14.1, 2.13.3, 1.123.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.26; >= 2.14.0, <= 2.14.0; >= 2.0.0-rc.0, < 2.13.3; fixed in 2.14.1, 2.13.3, 1.123.26

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-98c2-4cr3-4jc3 (OSV record GHSA-98c2-4cr3-4jc3 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3 (fixed))
- Verified: https://github.com/advisories/GHSA-98c2-4cr3-4jc3 (GitHub-reviewed advisory GHSA-98c2-4cr3-4jc3 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3)

Commands are suggestions: review each one before running it.

Loading voting…