Skip to content

← Actionable
Critical, CVSS 9.3

OpenTelemetry: Unsafe Deserialization in RMI Instrumentation may Lead to Remote Code Execution

CVE-2026-33701GHSA-xw7x-h9fj-p2c7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.opentelemetry.javaagent:opentelemetry-javaagent 2.26.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33701: 0.94% estimated exploitation activity in the next 30 days; percentile 60.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In versions prior to 2.26.1, the RMI instrumentation registered a custom endpoint that deserialized incoming data without applying serialization filters. An attacker with network access to a JMX or RMI port on an instrumented JVM could exploit this to potentially achieve remote code execution. All three of the following conditions must be true to exploit this vulnerability: 1. OpenTelemetry Java instrumentation is attached as a Java agent (-javaagent) 2. An RMI endpoint is network-reachable (e.g. JMX remote port, an RMI registry, or any application-exported RMI service) 3. A gadget-chain-compatible library is present on the classpath Impact Arbitrary remote code execution with the privileges of the user running the instrumented JVM. Recommendation Upgrade to version 2.26.1 or later. Workarounds Set the following system property to disable the RMI integration: Credits This vulnerability was responsibly disclosed in coordination with Datadog.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xw7x-h9fj-p2c7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33701

Advisory: OpenTelemetry: Unsafe Deserialization in RMI Instrumentation may Lead to Remote Code Execution
IDs: CVE-2026-33701, GHSA-xw7x-h9fj-p2c7
Record: https://patchnext.com/advisories/cve-2026-33701 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.opentelemetry.javaagent:opentelemetry-javaagent 2.26.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.opentelemetry.javaagent:opentelemetry-javaagent: affected < 2.26.1; fixed in 2.26.1

## Suggested inspection (read-only)
- Maven io.opentelemetry.javaagent:opentelemetry-javaagent: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.opentelemetry.javaagent:opentelemetry-javaagent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xw7x-h9fj-p2c7 (GitHub-reviewed advisory GHSA-xw7x-h9fj-p2c7 lists affected ranges: Maven io.opentelemetry.javaagent:opentelemetry-javaagent >=0 <2.26.1)

Commands are suggestions: review each one before running it.

Loading voting…