Sharp has Unrestricted File Upload via Client-Controlled Validation Rules
CVE-2026-33687GHSA-fr76-5637-w3g9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (code16/sharp 9.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist code16/sharp
- Affected
- < 9.20.0
- Fixed in
- 9.20.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fr76-5637-w3g9 lists affected ranges: Packagist code16/sharp >=0 <9.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33687: 0.53% estimated exploitation activity in the next 30 days; percentile 44.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The code16/sharp Laravel admin panel package contains a vulnerability in its file upload endpoint that allows authenticated users to bypass all file type restrictions. Details The upload endpoint within the ApiFormUploadController accepts a client-controlled validationrule parameter. This parameter is directly passed into the Laravel validator without sufficient server-side enforcement. By intercepting the request and sending validationrule[]=file, an attacker can completely bypass all MIME type and file extension restrictions. The vulnerable code is located in src/Http/Controllers/Api/ApiFormUploadController.php at line 24. Impact This vulnerability leads to several critical security risks: Attackers can upload arbitrary files, including PHP webshells, to the server. For more details on the package, visit: https://github.com/code16/sharp MIME type and extension validation can be bypassed entirely via client-controlled rules. Review the CWE definition here:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fr76-5637-w3g9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33687 Advisory: Sharp has Unrestricted File Upload via Client-Controlled Validation Rules IDs: CVE-2026-33687, GHSA-fr76-5637-w3g9 Record: https://patchnext.com/advisories/cve-2026-33687 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: code16/sharp 9.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist code16/sharp: affected < 9.20.0; fixed in 9.20.0 ## Suggested inspection (read-only) - Packagist code16/sharp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on code16/sharp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fr76-5637-w3g9 (GitHub-reviewed advisory GHSA-fr76-5637-w3g9 lists affected ranges: Packagist code16/sharp >=0 <9.20.0) Commands are suggestions: review each one before running it.
Loading voting…