Skip to content

← Actionable
Medium, CVSS 6.5

Vikjuna: Webhook BasicAuth Credentials Exposed to Read-Only Project Collaborators via API

CVE-2026-33677GHSA-7c2g-p23p-4jg3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.vikunja.io/api 2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-33677: 0.30% estimated exploitation activity in the next 30 days; percentile 23.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The GET /api/v1/projects/:project/webhooks endpoint returns webhook BasicAuth credentials (basicauthuser and basicauthpassword) in plaintext to any user with read access to the project. While the existing code correctly masks the HMAC secret field, the BasicAuth fields added in a later migration were not given the same treatment. This allows read-only collaborators to steal credentials intended for authenticating against external webhook receivers. Details When listing project webhooks, the ReadAll method in pkg/models/webhooks.go (line 203) only requires project read access: The Webhook struct defines both fields with JSON serialization tags, so they are included in API responses: The BasicAuth fields were added in migration 20260123000717 ("Add basic auth to webhooks"), but the credential masking logic at line 238 was not updated to include these new fields. The same issue exists in the user webhook listing at pkg/routes/api/v1/userwebhooks.go:65, where Secret is masked but…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7c2g-p23p-4jg3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33677

Advisory: Vikjuna: Webhook BasicAuth Credentials Exposed to Read-Only Project Collaborators via API
IDs: CVE-2026-33677, GHSA-7c2g-p23p-4jg3
Record: https://patchnext.com/advisories/cve-2026-33677 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.vikunja.io/api 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.vikunja.io/api: affected <= 2.2.0; fixed in 2.2.1

## Suggested inspection (read-only)
- Go code.vikunja.io/api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.vikunja.io/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7c2g-p23p-4jg3 (GitHub-reviewed advisory GHSA-7c2g-p23p-4jg3 lists affected ranges: Go code.vikunja.io/api >=0 <=2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…