PrestaShop: Improper Use of Validation Framework
CVE-2026-33674GHSA-283w-xf3q-788v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/prestashop 9.1.0, 8.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/prestashop
- Affected
- < 8.2.5>= 9.0.0-alpha.1, < 9.1.0
- Fixed in
- 9.1.0, 8.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-283w-xf3q-788v lists affected ranges: Packagist prestashop/prestashop >=0 =9.0.0-alpha.1 <9.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-33674: 0.25% estimated exploitation activity in the next 30 days; percentile 16.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Fix improper use of validation framework Patches Patched in 8.2.5 and 9.1.0 Workarounds None References none
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-283w-xf3q-788v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33674 Advisory: PrestaShop: Improper Use of Validation Framework IDs: CVE-2026-33674, GHSA-283w-xf3q-788v Record: https://patchnext.com/advisories/cve-2026-33674 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/prestashop 9.1.0, 8.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/prestashop: affected < 8.2.5; >= 9.0.0-alpha.1, < 9.1.0; fixed in 9.1.0, 8.2.5 ## Suggested inspection (read-only) - Packagist prestashop/prestashop: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/prestashop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-283w-xf3q-788v (GitHub-reviewed advisory GHSA-283w-xf3q-788v lists affected ranges: Packagist prestashop/prestashop >=0 =9.0.0-alpha.1 <9.1.0) Commands are suggestions: review each one before running it.
Loading voting…