Picomatch: Method Injection in POSIX Character Classes causes incorrect Glob Matching
CVE-2026-33672GHSA-3v7f-55p6-f55p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (picomatch 4.0.4, 3.0.2, 2.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm picomatch
- Affected
- >= 4.0.0, < 4.0.4>= 3.0.0, < 3.0.2< 2.3.2
- Fixed in
- 3.0.2, 4.0.4, 2.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3v7f-55p6-f55p lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3v7f-55p6-f55p lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-33672: 0.43% estimated exploitation activity in the next 30 days; percentile 36.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact picomatch is vulnerable to a method injection vulnerability (CWE-1321) affecting the POSIXREGEXSOURCE object. Because the object inherits from Object.prototype, specially crafted POSIX bracket expressions (e.g., [[:constructor:]]) can reference inherited method names. These methods are implicitly converted to strings and injected into the generated regular expression. This leads to incorrect glob matching behavior (integrity impact), where patterns may match unintended filenames. The issue does not enable remote code execution, but it can cause security-relevant logic errors in applications that rely on glob matching for filtering, validation, or access control. All users of affected picomatch versions that process untrusted or user-controlled glob patterns are potentially impacted. Patches This issue is fixed in picomatch 4.0.4, 3.0.2 and 2.3.2. Users should upgrade to one of these versions or later, depending on their supported release line. Workarounds If upgrading is not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3v7f-55p6-f55p
- Revision 1 · created ·
Published from osv record GHSA-3v7f-55p6-f55p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33672 Advisory: Picomatch: Method Injection in POSIX Character Classes causes incorrect Glob Matching IDs: CVE-2026-33672, GHSA-3v7f-55p6-f55p Record: https://patchnext.com/advisories/cve-2026-33672 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: picomatch 4.0.4, 3.0.2, 2.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm picomatch: affected >= 4.0.0, < 4.0.4; >= 3.0.0, < 3.0.2; < 2.3.2; fixed in 3.0.2, 4.0.4, 2.3.2 ## Suggested inspection (read-only) - `npm ls picomatch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on picomatch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3v7f-55p6-f55p (OSV record GHSA-3v7f-55p6-f55p lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-3v7f-55p6-f55p (GitHub-reviewed advisory GHSA-3v7f-55p6-f55p lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2) Commands are suggestions: review each one before running it.
Loading voting…