Picomatch has a ReDoS vulnerability via extglob quantifiers
CVE-2026-33671GHSA-c2c7-rcm5-vvqj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (picomatch 4.0.4, 3.0.2, 2.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm picomatch
- Affected
- >= 4.0.0, < 4.0.4>= 3.0.0, < 3.0.2< 2.3.2
- Fixed in
- 3.0.2, 4.0.4, 2.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c2c7-rcm5-vvqj lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c2c7-rcm5-vvqj lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-33671: 0.42% estimated exploitation activity in the next 30 days; percentile 36.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact picomatch is vulnerable to Regular Expression Denial of Service (ReDoS) when processing crafted extglob patterns. Certain patterns using extglob quantifiers such as +() and (), especially when combined with overlapping alternatives or nested extglobs, are compiled into regular expressions that can exhibit catastrophic backtracking on non-matching input. Examples of problematic patterns include +(a|aa), +(|?), +(+(a)), (+(a)), and +(+(+(a))). In local reproduction, these patterns caused multi-second event-loop blocking with relatively short inputs. For example, +(a|aa) compiled to ^(?:(?=.)(?:a|aa)+)$ and took about 2 seconds to reject a 41-character non-matching input, while nested patterns such as +(+(a)) and (+(a)) took around 29 seconds to reject a 33-character input on a modern M1 MacBook. Applications are impacted when they allow untrusted users to supply glob patterns that are passed to picomatch for compilation or matching. In those cases, an attacker can cause…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c2c7-rcm5-vvqj
- Revision 1 · created ·
Published from osv record GHSA-c2c7-rcm5-vvqj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33671 Advisory: Picomatch has a ReDoS vulnerability via extglob quantifiers IDs: CVE-2026-33671, GHSA-c2c7-rcm5-vvqj Record: https://patchnext.com/advisories/cve-2026-33671 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: picomatch 4.0.4, 3.0.2, 2.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm picomatch: affected >= 4.0.0, < 4.0.4; >= 3.0.0, < 3.0.2; < 2.3.2; fixed in 3.0.2, 4.0.4, 2.3.2 ## Suggested inspection (read-only) - `npm ls picomatch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on picomatch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c2c7-rcm5-vvqj (OSV record GHSA-c2c7-rcm5-vvqj lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-c2c7-rcm5-vvqj (GitHub-reviewed advisory GHSA-c2c7-rcm5-vvqj lists affected ranges: npm picomatch >=4.0.0 =3.0.0 =0 <2.3.2) Commands are suggestions: review each one before running it.
Loading voting…