Skip to content

← Actionable
High, CVSS 7.1

Vikunja Allows Disabled/Locked User Accounts to Authenticate via API Tokens, CalDAV, and OpenID Connect

CVE-2026-33668GHSA-94xm-jj8x-3cr4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.vikunja.io/api 2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33668: 0.46% estimated exploitation activity in the next 30 days; percentile 40.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When a user account is disabled or locked, the status check is only enforced on the local login and JWT token refresh paths. Three other authentication paths — API tokens, CalDAV basic auth, and OpenID Connect — do not verify user status, allowing disabled or locked users to continue accessing the API and syncing data. Details User status (StatusDisabled, StatusAccountLocked) is checked in only two places: 1. Local/LDAP login (pkg/routes/api/v1/login.go:74) — prevents issuing new JWTs 2. JWT token refresh (pkg/routes/api/v1/login.go:247) — prevents refreshing expired JWTs Three other authentication paths fetch the user from the database via GetUserByID but never inspect the returned user's status: 1. API Token Authentication (pkg/routes/apitokens.go:76-103) API tokens are long-lived (up to years) and have no refresh cycle. A disabled user's API tokens remain fully functional until they expire naturally. 2. CalDAV Basic Auth (pkg/routes/caldav/auth.go) The CalDAV basic auth…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-94xm-jj8x-3cr4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33668

Advisory: Vikunja Allows Disabled/Locked User Accounts to Authenticate via API Tokens, CalDAV, and OpenID Connect
IDs: CVE-2026-33668, GHSA-94xm-jj8x-3cr4
Record: https://patchnext.com/advisories/cve-2026-33668 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.vikunja.io/api 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.vikunja.io/api: affected >= 0.18.0, <= 2.2.0; fixed in 2.2.1

## Suggested inspection (read-only)
- Go code.vikunja.io/api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.vikunja.io/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-94xm-jj8x-3cr4 (GitHub-reviewed advisory GHSA-94xm-jj8x-3cr4 lists affected ranges: Go code.vikunja.io/api >=0.18.0 <=2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…