n8n: LDAP Email-Based Account Linking Allows Privilege Escalation and Account Takeover
CVE-2026-33665GHSA-c545-x2rh-82fc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.4.0, 1.121.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 2.0.0-rc.0, < 2.4.0< 1.121.0
- Fixed in
- 2.4.0, 1.121.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c545-x2rh-82fc lists affected ranges: npm n8n >=2.0.0-rc.0 =0 <1.121.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c545-x2rh-82fc lists affected ranges: npm n8n >=2.0.0-rc.0 =0 <1.121.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:L · score source
- EPSS
- CVE-2026-33665: 0.33% estimated exploitation activity in the next 30 days; percentile 26.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When LDAP authentication is enabled, n8n automatically linked an LDAP identity to an existing local account if the LDAP email attribute matched the local account's email. An authenticated LDAP user who could control their own LDAP email attribute could set it to match another user's email — including an administrator's — and upon login gain full access to that account. The account linkage persisted even if the LDAP email was later reverted, resulting in a permanent account takeover. - LDAP authentication must be configured and active (non-default). Patches The issue has been fixed in n8n versions 2.4.0 and 1.121.0. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Disable LDAP authentication until the instance can be upgraded. - Restrict LDAP directory permissions so that users cannot modify their own email attributes.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c545-x2rh-82fc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c545-x2rh-82fc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33665 Advisory: n8n: LDAP Email-Based Account Linking Allows Privilege Escalation and Account Takeover IDs: CVE-2026-33665, GHSA-c545-x2rh-82fc Record: https://patchnext.com/advisories/cve-2026-33665 (revision 3, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.4.0, 1.121.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 2.0.0-rc.0, < 2.4.0; < 1.121.0; fixed in 2.4.0, 1.121.0 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c545-x2rh-82fc (OSV record GHSA-c545-x2rh-82fc lists affected ranges: npm n8n >=2.0.0-rc.0 =0 <1.121.0 (fixed)) - Verified: https://github.com/advisories/GHSA-c545-x2rh-82fc (GitHub-reviewed advisory GHSA-c545-x2rh-82fc lists affected ranges: npm n8n >=2.0.0-rc.0 =0 <1.121.0) Commands are suggestions: review each one before running it.
Loading voting…