n8n is Vulnerable to Credential Theft via Name-Based Resolution and Permission Checker Bypass in Community Edition
CVE-2026-33663GHSA-m63j-689w-3j35
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.14.1, 2.13.3, 1.123.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.27>= 2.14.0, <= 2.14.0>= 2.0.0-rc.0, < 2.13.3
- Fixed in
- 1.123.27, 2.14.1, 2.13.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m63j-689w-3j35 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m63j-689w-3j35 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-33663: 0.40% estimated exploitation activity in the next 30 days; percentile 34.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user with the global:member role could exploit chained authorization flaws in n8n's credential pipeline to steal plaintext secrets from generic HTTP credentials (httpBasicAuth, httpHeaderAuth, httpQueryAuth) belonging to other users on the same instance. The attack abuses a name-based credential resolution path that does not enforce ownership or project scope, combined with a bypass in the credentials permission checker that causes generic HTTP credential types to be skipped during pre-execution validation. Together, these flaws allow a member-role user to resolve another user's credential ID and execute a workflow that decrypts and uses that credential without authorization. Native integration credential types (e.g. slackApi, openAiApi, postgres) are not affected by this issue. This vulnerability affects Community Edition only. Enterprise Edition has additional permission gates on workflow creation and execution that independently block this attack chain.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m63j-689w-3j35
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m63j-689w-3j35
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33663 Advisory: n8n is Vulnerable to Credential Theft via Name-Based Resolution and Permission Checker Bypass in Community Edition IDs: CVE-2026-33663, GHSA-m63j-689w-3j35 Record: https://patchnext.com/advisories/cve-2026-33663 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.14.1, 2.13.3, 1.123.27. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.27; >= 2.14.0, <= 2.14.0; >= 2.0.0-rc.0, < 2.13.3; fixed in 1.123.27, 2.14.1, 2.13.3 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m63j-689w-3j35 (OSV record GHSA-m63j-689w-3j35 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3 (fixed)) - Verified: https://github.com/advisories/GHSA-m63j-689w-3j35 (GitHub-reviewed advisory GHSA-m63j-689w-3j35 lists affected ranges: npm n8n >=0 =2.14.0 =2.0.0-rc.0 <2.13.3) Commands are suggestions: review each one before running it.
Loading voting…