n8n has Multiple Remote Code Execution Vulnerabilities in Merge Node AlaSQL SQL Mode
CVE-2026-33660GHSA-58qr-rcgv-642v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.14.1, 2.13.3, 1.123.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 2.14.0, <= 2.14.0>= 2.0.0-rc.0, < 2.13.3< 1.123.27
- Fixed in
- 1.123.27, 2.14.1, 2.13.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-58qr-rcgv-642v lists affected ranges: npm n8n >=2.14.0 =2.0.0-rc.0 =0 <1.123.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-58qr-rcgv-642v lists affected ranges: npm n8n >=2.14.0 =2.0.0-rc.0 =0 <1.123.27 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-33660: 0.97% estimated exploitation activity in the next 30 days; percentile 61.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user with permission to create or modify workflows could use the Merge node's "Combine by SQL" mode to read local files on the n8n host and achieve remote code execution. The AlaSQL sandbox did not sufficiently restrict certain SQL statements, allowing an attacker to access sensitive files on the server or even compromise the intance. Patches The issue has been fixed in n8n versions 2.14.1, 2.13.3, and 1.123.27. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Merge node by adding n8n-nodes-base.merge to the NODESEXCLUDE environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-58qr-rcgv-642v
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-58qr-rcgv-642v
- Revision 1 · created ·
Published from ghsa record GHSA-58qr-rcgv-642v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33660 Advisory: n8n has Multiple Remote Code Execution Vulnerabilities in Merge Node AlaSQL SQL Mode IDs: CVE-2026-33660, GHSA-58qr-rcgv-642v Record: https://patchnext.com/advisories/cve-2026-33660 (revision 4, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.14.1, 2.13.3, 1.123.27. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 2.14.0, <= 2.14.0; >= 2.0.0-rc.0, < 2.13.3; < 1.123.27; fixed in 1.123.27, 2.14.1, 2.13.3 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-58qr-rcgv-642v (GitHub-reviewed advisory GHSA-58qr-rcgv-642v lists affected ranges: npm n8n >=2.14.0 =2.0.0-rc.0 =0 <1.123.27) - Verified: https://osv.dev/vulnerability/GHSA-58qr-rcgv-642v (OSV record GHSA-58qr-rcgv-642v lists affected ranges: npm n8n >=2.14.0 =2.0.0-rc.0 =0 <1.123.27 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…