Glances Vulnerable to Command Injection via Dynamic Configuration Values
CVE-2026-33641GHSA-qhj7-v7h7-q4c7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI glances
- Affected
- <= 4.5.2
- Fixed in
- 4.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qhj7-v7h7-q4c7 lists affected ranges: PyPI glances >=0 <4.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qhj7-v7h7-q4c7 lists affected ranges: PyPI glances >=0 <=4.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33641: 0.90% estimated exploitation activity in the next 30 days; percentile 59.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Glances supports dynamic configuration values in which substrings enclosed in backticks are executed as system commands during configuration parsing. This behavior occurs in Config.getvalue() and is implemented without validation or restriction of the executed commands. If an attacker can modify or influence configuration files, arbitrary commands will execute automatically with the privileges of the Glances process during startup or configuration reload. In deployments where Glances runs with elevated privileges (e.g., as a system service), this may lead to privilege escalation. Details 1. Glances loads configuration files from user, system, or custom paths during initialization. 2. When retrieving a configuration value, Config.getvalue() scans for substrings enclosed in backticks. File: glances/config.py 3. The extracted string is passed directly to systemexec(). File: glances/globals.py 4. The command is executed and its output replaces the original configuration value.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qhj7-v7h7-q4c7
- Revision 1 · created ·
Published from osv record GHSA-qhj7-v7h7-q4c7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33641 Advisory: Glances Vulnerable to Command Injection via Dynamic Configuration Values IDs: CVE-2026-33641, GHSA-qhj7-v7h7-q4c7 Record: https://patchnext.com/advisories/cve-2026-33641 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glances 4.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI glances: affected <= 4.5.2; fixed in 4.5.3 ## Suggested inspection (read-only) - `python -m pip show glances`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glances. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qhj7-v7h7-q4c7 (OSV record GHSA-qhj7-v7h7-q4c7 lists affected ranges: PyPI glances >=0 <4.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-qhj7-v7h7-q4c7 (GitHub-reviewed advisory GHSA-qhj7-v7h7-q4c7 lists affected ranges: PyPI glances >=0 <=4.5.2) Commands are suggestions: review each one before running it.
Loading voting…