Ech0 authenticated user-list exposed data via public /api/allusers endpoint
CVE-2026-33638GHSA-m983-7426-5hrj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/lin-snow/ech0 1.4.8-0.20260322121226-acbf1fd71011), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.4.8-0.20260322121226-acbf1fd71011
- Fixed in
- 1.4.8-0.20260322121226-acbf1fd71011
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m983-7426-5hrj lists affected ranges: Go github.com/lin-snow/ech0 >=0 <1.4.8-0.20260322121226-acbf1fd71011
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-33638: 0.50% estimated exploitation activity in the next 30 days; percentile 43.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A public access-control flaw allows unauthenticated users to retrieve the full user list from GET /api/allusers. This exposes user profile metadata to anyone who can reach the application and enables remote user enumeration. Details The vulnerable route is registered as a public endpoint: - internal/router/user.go:17 - appRouterGroup.PublicRouterGroup.GET("/allusers", h.UserHandler.GetAllUsers()) However, the handler appears to have been intended as an authenticated endpoint: - internal/handler/user/user.go:177-185 - API annotations indicate an authentication requirement via @Security ApiKeyAuth This creates a mismatch between the documented security model and the actual routing configuration. As a result, requests to GET /api/allusers succeed without authentication and return user records, including profile metadata such as usernames, email addresses, role-related flags, avatar values, and locale information. A negative control against another endpoint that correctly…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m983-7426-5hrj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33638 Advisory: Ech0 authenticated user-list exposed data via public `/api/allusers` endpoint IDs: CVE-2026-33638, GHSA-m983-7426-5hrj Record: https://patchnext.com/advisories/cve-2026-33638 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/lin-snow/ech0 1.4.8-0.20260322121226-acbf1fd71011. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/lin-snow/ech0: affected < 1.4.8-0.20260322121226-acbf1fd71011; fixed in 1.4.8-0.20260322121226-acbf1fd71011 ## Suggested inspection (read-only) - Go github.com/lin-snow/ech0: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/lin-snow/ech0. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m983-7426-5hrj (GitHub-reviewed advisory GHSA-m983-7426-5hrj lists affected ranges: Go github.com/lin-snow/ech0 >=0 <1.4.8-0.20260322121226-acbf1fd71011) Commands are suggestions: review each one before running it.
Loading voting…