LMDeploy vulnerable to arbitrary code execution via eval() of untrusted quant_dtype in model config loading
CVE-2026-33625GHSA-3hmm-rh5q-gwwr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lmdeploy 0.12.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lmdeploy
- Affected
- >= 0.12.1, < 0.12.3
- Fixed in
- 0.12.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3hmm-rh5q-gwwr lists affected ranges: PyPI lmdeploy >=0.12.1 <0.12.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3hmm-rh5q-gwwr lists affected ranges: PyPI lmdeploy >=0.12.1 <0.12.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-33625: 0.44% estimated exploitation activity in the next 30 days; percentile 38.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary lmdeploy <= latest contains a code injection vulnerability in lmdeploy/pytorch/config.py line 620 that allows an attacker to execute arbitrary Python code by publishing a malicious HuggingFace model with a crafted quantizationconfig.quantdtype value. When a user loads the model with lmdeploy, the quantdtype is passed to eval(f'torch.{quantdtype}') without any validation. Details Vulnerable code (permalink): The quantdtype value comes from the model's quantizationconfig in its HuggingFace config. When a model specifies quantmethod: awq, the AWQ branch processes the config but does NOT override quantdtype, allowing the malicious value to reach the eval() call. Attack vector: An attacker publishes a HuggingFace model with: Note: The updatetorchdtype method at line 53 has a whitelist check, but that's for torchdtype, NOT quantdtype. The quantdtype at line 620 has no validation whatsoever. PoC Output: Impact An attacker who publishes a malicious model on HuggingFace Hub can…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3hmm-rh5q-gwwr
- Revision 2 · amended ·
Amended from osv record GHSA-3hmm-rh5q-gwwr
- Revision 1 · created ·
Published from ghsa record GHSA-3hmm-rh5q-gwwr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33625 Advisory: LMDeploy vulnerable to arbitrary code execution via eval() of untrusted quant_dtype in model config loading IDs: CVE-2026-33625, GHSA-3hmm-rh5q-gwwr Record: https://patchnext.com/advisories/cve-2026-33625 (revision 3, source checked 26 Oct 2026, 13:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lmdeploy 0.12.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lmdeploy: affected >= 0.12.1, < 0.12.3; fixed in 0.12.3 ## Suggested inspection (read-only) - `python -m pip show lmdeploy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lmdeploy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3hmm-rh5q-gwwr (GitHub-reviewed advisory GHSA-3hmm-rh5q-gwwr lists affected ranges: PyPI lmdeploy >=0.12.1 <0.12.3) - Verified: https://osv.dev/vulnerability/GHSA-3hmm-rh5q-gwwr (OSV record GHSA-3hmm-rh5q-gwwr lists affected ranges: PyPI lmdeploy >=0.12.1 <0.12.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…