OpenClaw: /pair approve command path omitted caller scope subsetting and reopened device pairing escalation
CVE-2026-33579GHSA-hc5h-pmr3-3497
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.3.24
- Fixed in
- 2026.3.28
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hc5h-pmr3-3497 lists affected ranges: npm openclaw >=0 <=2026.3.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hc5h-pmr3-3497 lists affected ranges: npm openclaw >=0 <2026.3.28 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-33579: 0.84% estimated exploitation activity in the next 30 days; percentile 57.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The /pair approve command path called device approval without forwarding caller scopes into the core approval check. Impact A caller that held pairing privileges but not admin privileges could approve a pending device request asking for broader scopes, including admin access. Affected Component extensions/device-pair/index.ts, src/infra/device-pairing.ts Fixed Versions - Affected: <= 2026.3.24 - Patched: = 2026.3.28 - Latest stable 2026.3.28 contains the fix. Fix Fixed by commit 4ee4960de2 (Pairing: forward caller scopes during approval). OpenClaw thanks @AntAISecurityLab for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-hc5h-pmr3-3497
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-hc5h-pmr3-3497
- Revision 1 · created ·
Published from ghsa record GHSA-hc5h-pmr3-3497
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33579 Advisory: OpenClaw: /pair approve command path omitted caller scope subsetting and reopened device pairing escalation IDs: CVE-2026-33579, GHSA-hc5h-pmr3-3497 Record: https://patchnext.com/advisories/cve-2026-33579 (revision 4, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.28. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.3.24; fixed in 2026.3.28 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hc5h-pmr3-3497 (GitHub-reviewed advisory GHSA-hc5h-pmr3-3497 lists affected ranges: npm openclaw >=0 <=2026.3.24) - Verified: https://osv.dev/vulnerability/GHSA-hc5h-pmr3-3497 (OSV record GHSA-hc5h-pmr3-3497 lists affected ranges: npm openclaw >=0 <2026.3.28 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…