Skip to content

← Actionable
Medium, CVSS 6.9amended

OpenClaw: Pairing setup codes exposed long-lived shared gateway credentials instead of short-lived bootstrap tokens

CVE-2026-33575GHSA-7h7g-x2px-94hj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.3.11
    Fixed in
    2026.3.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-33575: 0.25% estimated exploitation activity in the next 30 days; percentile 16.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenClaw pairing setup codes generated by /pair and openclaw qr embedded the configured shared gateway token or password directly in the setup payload. Anyone who obtained that code from chat history, logs, screenshots, or copied QR payloads could recover the long-lived shared credential. Impact An attacker with access to a leaked setup code could reuse the shared gateway credential outside the intended one-time pairing flow. Affected versions openclaw <= 2026.3.11 Patch Fixed in openclaw 2026.3.12. Setup codes now carry short-lived bootstrap tokens that are only valid for the initial device bootstrap exchange. Update to 2026.3.12 or later and rotate any previously exposed shared gateway credentials if setup codes may have leaked.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7h7g-x2px-94hj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7h7g-x2px-94hj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33575

Advisory: OpenClaw: Pairing setup codes exposed long-lived shared gateway credentials instead of short-lived bootstrap tokens
IDs: CVE-2026-33575, GHSA-7h7g-x2px-94hj
Record: https://patchnext.com/advisories/cve-2026-33575 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.3.11; fixed in 2026.3.12

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7h7g-x2px-94hj (OSV record GHSA-7h7g-x2px-94hj lists affected ranges: npm openclaw >=0 <2026.3.12 (fixed))
- Verified: https://github.com/advisories/GHSA-7h7g-x2px-94hj (GitHub-reviewed advisory GHSA-7h7g-x2px-94hj lists affected ranges: npm openclaw >=0 <=2026.3.11)

Commands are suggestions: review each one before running it.

Loading voting…