OpenClaw's skills-install-download can be redirected outside the tools root by rebinding the validated base path
CVE-2026-33574GHSA-vhwf-4x96-vqx2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.3.7
- Fixed in
- 2026.3.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vhwf-4x96-vqx2 lists affected ranges: npm openclaw >=0 <2026.3.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vhwf-4x96-vqx2 lists affected ranges: npm openclaw >=0 <=2026.3.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33574: 0.09% estimated exploitation activity in the next 30 days; percentile 0.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OpenClaw's skills download installer validated the intended per-skill tools root lexically, but later reused that mutable path while downloading and copying the archive into place. If a local attacker could rebind that tools-root path between validation and the final write, the installer could be redirected to write outside the intended tools directory. The fix pins the canonical per-skill tools root immediately after validation and derives later download/copy paths from that canonical root, so rebinding the lexical path fails closed instead of redirecting the write. Affected Packages / Versions - Package: openclaw (npm) - Latest published vulnerable version: 2026.3.7 - Affected range: <= 2026.3.7 - Fixed in released version: 2026.3.8 Fix Commit(s) - 9abf014f3502009faf9c73df5ca2cff719e54639 Release Verification - Verified fixed in GitHub release v2026.3.8 published on March 9, 2026. - Verified npm view openclaw version resolves to 2026.3.8. - Verified the release contains the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vhwf-4x96-vqx2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vhwf-4x96-vqx2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33574 Advisory: OpenClaw's skills-install-download can be redirected outside the tools root by rebinding the validated base path IDs: CVE-2026-33574, GHSA-vhwf-4x96-vqx2 Record: https://patchnext.com/advisories/cve-2026-33574 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.3.7; fixed in 2026.3.8 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vhwf-4x96-vqx2 (OSV record GHSA-vhwf-4x96-vqx2 lists affected ranges: npm openclaw >=0 <2026.3.8 (fixed)) - Verified: https://github.com/advisories/GHSA-vhwf-4x96-vqx2 (GitHub-reviewed advisory GHSA-vhwf-4x96-vqx2 lists affected ranges: npm openclaw >=0 <=2026.3.7) Commands are suggestions: review each one before running it.
Loading voting…