OpenClaw session transcript files were created without forced user-only permissions
CVE-2026-33572GHSA-vr7j-g7jv-h5mp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.2.15
- Fixed in
- 2026.2.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vr7j-g7jv-h5mp lists affected ranges: npm openclaw >=0 <2026.2.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vr7j-g7jv-h5mp lists affected ranges: npm openclaw >=0 <=2026.2.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33572: 0.12% estimated exploitation activity in the next 30 days; percentile 1.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
openclaw created new session transcript JSONL files with overly broad default permissions in affected releases. On multi-user hosts, other local users or processes could read transcript contents, including secrets that might appear in tool output. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.15 - First fixed version: 2026.2.17 - Current latest npm release checked during verification: 2026.3.13 (not affected) Impact Session transcript JSONL files are created under the local OpenClaw session store. In affected releases, newly created transcript files did not force user-only permissions, so transcript contents could be readable by other local users depending on the host environment and umask behavior. Fix New transcript files are now created with 0o600 permissions. Existing transcript permission drift is also remediated by the security audit fix flow. Verified in code: - src/config/sessions/transcript.ts:82 writes new transcript files with mode:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vr7j-g7jv-h5mp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vr7j-g7jv-h5mp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33572 Advisory: OpenClaw session transcript files were created without forced user-only permissions IDs: CVE-2026-33572, GHSA-vr7j-g7jv-h5mp Record: https://patchnext.com/advisories/cve-2026-33572 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.2.15; fixed in 2026.2.17 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vr7j-g7jv-h5mp (OSV record GHSA-vr7j-g7jv-h5mp lists affected ranges: npm openclaw >=0 <2026.2.17 (fixed)) - Verified: https://github.com/advisories/GHSA-vr7j-g7jv-h5mp (GitHub-reviewed advisory GHSA-vr7j-g7jv-h5mp lists affected ranges: npm openclaw >=0 <=2026.2.15) Commands are suggestions: review each one before running it.
Loading voting…