Apache Kafka does not validate JWT tokens in its OAUTHBEARER authentication implementation
CVE-2026-33557GHSA-28jg-cgg7-j4wc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kafka:kafka-clients 4.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.kafka:kafka-clients
- Affected
- >= 4.1.0, < 4.1.2
- Fixed in
- 4.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-28jg-cgg7-j4wc lists affected ranges: Maven org.apache.kafka:kafka-clients >=4.1.0 <4.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-33557: 0.90% estimated exploitation activity in the next 30 days; percentile 59.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A security vulnerability has been identified in Apache Kafka. By default, the broker property sasl.oauthbearer.jwt.validator.class is set to org.apache.kafka.common.security.oauthbearer.DefaultJwtValidator. It accepts any JWT token without validating its signature, issuer, or audience. An attacker can generate a JWT token from any issuer with the preferredusername set to any user, and the broker will accept it. Apache advises Kafka users using kafka v4.1.0 or v4.1.1 to set the config sasl.oauthbearer.jwt.validator.class to org.apache.kafka.common.security.oauthbearer.BrokerJwtValidator explicitly to avoid this vulnerability. Since Kafka v4.1.2 and v4.2.0 and later, the issue is fixed and will correctly validate the JWT token.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-28jg-cgg7-j4wc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33557 Advisory: Apache Kafka does not validate JWT tokens in its OAUTHBEARER authentication implementation IDs: CVE-2026-33557, GHSA-28jg-cgg7-j4wc Record: https://patchnext.com/advisories/cve-2026-33557 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.kafka:kafka-clients 4.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.kafka:kafka-clients: affected >= 4.1.0, < 4.1.2; fixed in 4.1.2 ## Suggested inspection (read-only) - Maven org.apache.kafka:kafka-clients: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.kafka:kafka-clients. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-28jg-cgg7-j4wc (GitHub-reviewed advisory GHSA-28jg-cgg7-j4wc lists affected ranges: Maven org.apache.kafka:kafka-clients >=4.1.0 <4.1.2) Commands are suggestions: review each one before running it.
Loading voting…