OpenStack Keystone: Restricted application credentials can create EC2 credentials
CVE-2026-33551GHSA-4phw-6824-6cfp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 26.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keystone
- Affected
- >= 14.0.0, < 26.1.1
- Fixed in
- 26.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4phw-6824-6cfp lists affected ranges: PyPI keystone >=14.0.0 <26.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4phw-6824-6cfp lists affected ranges: PyPI keystone >=14.0.0 <26.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N
- EPSS
- CVE-2026-33551: 0.22% estimated exploitation activity in the next 30 days; percentile 12.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenStack Keystone 14 through 26 before 26.1.1, 27.0.0, 28.0.0, and 29.0.0. Restricted application credentials can create EC2 credentials. By using a restricted application credential to call the EC2 credential creation API, an authenticated user with only a reader role may obtain an EC2/S3 credential that carries the full set of the parent user's S3 permissions, effectively bypassing the role restrictions imposed on the application credential. Only deployments that use restricted application credentials in combination with the EC2/S3 compatibility API (swift3 / s3api) are affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4phw-6824-6cfp
- Revision 1 · created ·
Published from osv record GHSA-4phw-6824-6cfp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33551 Advisory: OpenStack Keystone: Restricted application credentials can create EC2 credentials IDs: CVE-2026-33551, GHSA-4phw-6824-6cfp Record: https://patchnext.com/advisories/cve-2026-33551 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keystone 26.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keystone: affected >= 14.0.0, < 26.1.1; fixed in 26.1.1 ## Suggested inspection (read-only) - `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keystone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4phw-6824-6cfp (OSV record GHSA-4phw-6824-6cfp lists affected ranges: PyPI keystone >=14.0.0 <26.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-4phw-6824-6cfp (GitHub-reviewed advisory GHSA-4phw-6824-6cfp lists affected ranges: PyPI keystone >=14.0.0 <26.1.1) Commands are suggestions: review each one before running it.
Loading voting…