Distribution affected by pull-through cache credential exfiltration via www-authenticate bearer realm
CVE-2026-33540GHSA-3p65-76g6-3w7r
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/distribution/distribution
- Affected
- <= 2.8.3
- Fixed in
- no fixed version recorded
Go github.com/distribution/distribution/v3
- Affected
- < 3.1.0
- Fixed in
- 3.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3p65-76g6-3w7r lists affected ranges: Go github.com/distribution/distribution/v3 >=0 =0 <=2.8.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-33540: 0.29% estimated exploitation activity in the next 30 days; percentile 21.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
hi guys, commit: 40594bd98e6d6ed993b5c6021c93fdf96d2e5851 (as-of 2026-01-31) contact: GitHub Security Advisory (https://github.com/distribution/distribution/security/advisories/new) summary in pull-through cache mode, distribution discovers token auth endpoints by parsing WWW-Authenticate challenges returned by the configured upstream registry. the realm URL from a bearer challenge is used without validating that it matches the upstream registry host. as a result, an attacker-controlled upstream (or an attacker with MitM position to the upstream) can cause distribution to send the configured upstream credentials via basic auth to an attacker-controlled realm URL. this is the same vulnerability class as CVE-2020-15157 (containerd), but in distribution’s pull-through cache proxy auth flow. severity HIGH note: the baseline impact is credential disclosure of the configured upstream credentials. if a deployment uses broader credentials for upstream auth (for example cloud iam…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3p65-76g6-3w7r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33540 Advisory: Distribution affected by pull-through cache credential exfiltration via www-authenticate bearer realm IDs: CVE-2026-33540, GHSA-3p65-76g6-3w7r Record: https://patchnext.com/advisories/cve-2026-33540 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/distribution/distribution/v3 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/distribution/distribution: affected <= 2.8.3 - Go github.com/distribution/distribution/v3: affected < 3.1.0; fixed in 3.1.0 ## Suggested inspection (read-only) - Go github.com/distribution/distribution: check the installed version with your package manager. - Go github.com/distribution/distribution/v3: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/distribution/distribution, github.com/distribution/distribution/v3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3p65-76g6-3w7r (GitHub-reviewed advisory GHSA-3p65-76g6-3w7r lists affected ranges: Go github.com/distribution/distribution/v3 >=0 =0 <=2.8.3) Commands are suggestions: review each one before running it.
Loading voting…