Glances Vulnerable to Cross-Origin System Information Disclosure via XML-RPC Server CORS Wildcard
CVE-2026-33533GHSA-7p93-6934-f4q7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI glances
- Affected
- < 4.5.3
- Fixed in
- 4.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7p93-6934-f4q7 lists affected ranges: PyPI glances >=0 <4.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7p93-6934-f4q7 lists affected ranges: PyPI glances >=0 <4.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-33533: 0.34% estimated exploitation activity in the next 30 days; percentile 28.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Glances XML-RPC server (activated with glances -s or glances --server) sends Access-Control-Allow-Origin: on every HTTP response. Because the XML-RPC handler does not validate the Content-Type header, an attacker-controlled webpage can issue a CORS "simple request" (POST with Content-Type: text/plain) containing a valid XML-RPC payload. The browser sends the request without a preflight check, the server processes the XML body and returns the full system monitoring dataset, and the wildcard CORS header lets the attacker's JavaScript read the response. The result is complete exfiltration of hostname, OS version, IP addresses, CPU/memory/disk/network stats, and the full process list including command lines (which often contain tokens, passwords, or internal paths). Details File: glances/server.py, class GlancesXMLRPCHandler, line 41 This header is attached to every response from the XML-RPC server. The server inherits from SimpleXMLRPCRequestHandler which parses the POST…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7p93-6934-f4q7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7p93-6934-f4q7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33533 Advisory: Glances Vulnerable to Cross-Origin System Information Disclosure via XML-RPC Server CORS Wildcard IDs: CVE-2026-33533, GHSA-7p93-6934-f4q7 Record: https://patchnext.com/advisories/cve-2026-33533 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glances 4.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI glances: affected < 4.5.3; fixed in 4.5.3 ## Suggested inspection (read-only) - `python -m pip show glances`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glances. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7p93-6934-f4q7 (OSV record GHSA-7p93-6934-f4q7 lists affected ranges: PyPI glances >=0 <4.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-7p93-6934-f4q7 (GitHub-reviewed advisory GHSA-7p93-6934-f4q7 lists affected ranges: PyPI glances >=0 <4.5.3) Commands are suggestions: review each one before running it.
Loading voting…