Skip to content

← Actionable
Medium, CVSS 4.3amended

yaml is vulnerable to Stack Overflow via deeply nested YAML collections

CVE-2026-33532GHSA-48c2-rrv3-qjmp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yaml 2.8.3, 1.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm yaml

    Affected
    >= 2.0.0, < 2.8.3>= 1.0.0, < 1.10.3
    Fixed in
    1.10.3, 2.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-33532: 0.49% estimated exploitation activity in the next 30 days; percentile 42.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Parsing a YAML document with yaml may throw a RangeError due to a stack overflow. The node resolution/composition phase uses recursive function calls without a depth bound. An attacker who can supply YAML for parsing can trigger a RangeError: Maximum call stack size exceeded with a small payload (~2–10 KB). The RangeError is not a YAMLParseError, so applications that only catch YAML-specific errors will encounter an unexpected exception type. Depending on the host application's exception handling, this can fail requests or terminate the Node.js process. Flow sequences allow deep nesting with minimal bytes (2 bytes per level: one [ and one ]). On the default Node.js stack, approximately 1,000–5,000 levels of nesting (2–10 KB input) exhaust the call stack. The exact threshold is environment-dependent (Node.js version, stack size, call stack depth at invocation). Note: the library's Parser (CST phase) uses a stack-based iterative approach and is not affected. Only the compose/resolve…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-48c2-rrv3-qjmp

  2. Revision 1 · created ·

    Published from osv record GHSA-48c2-rrv3-qjmp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33532

Advisory: yaml is vulnerable to Stack Overflow via deeply nested YAML collections
IDs: CVE-2026-33532, GHSA-48c2-rrv3-qjmp
Record: https://patchnext.com/advisories/cve-2026-33532 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yaml 2.8.3, 1.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm yaml: affected >= 2.0.0, < 2.8.3; >= 1.0.0, < 1.10.3; fixed in 1.10.3, 2.8.3

## Suggested inspection (read-only)
- `npm ls yaml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-48c2-rrv3-qjmp (OSV record GHSA-48c2-rrv3-qjmp lists affected ranges: npm yaml >=2.0.0 =1.0.0 <1.10.3 (fixed))
- Verified: https://github.com/advisories/GHSA-48c2-rrv3-qjmp (GitHub-reviewed advisory GHSA-48c2-rrv3-qjmp lists affected ranges: npm yaml >=2.0.0 =1.0.0 <1.10.3)

Commands are suggestions: review each one before running it.

Loading voting…