Authelia: Improper Neutralization of Input During Web Page Generation Leads to Potential Cross-site Scripting
CVE-2026-33525GHSA-gmfg-3v4q-9qr4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/authelia/authelia/v4 4.39.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/authelia/authelia/v4
- Affected
- >= 4.39.15, <= 4.39.15
- Fixed in
- 4.39.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gmfg-3v4q-9qr4 lists affected ranges: Go github.com/authelia/authelia/v4 >=4.39.15 <=4.39.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 0.5 · CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:U/S:N/AU:Y/R:U/V:D/RE:L/U:Clear · score source
- EPSS
- CVE-2026-33525: 0.24% estimated exploitation activity in the next 30 days; percentile 14.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Official Weighted Severity Rating: Low This exploit is very unlikely to be the case for most users as it requires configuration of the Content Security Policy template value. Below represents a safe value, any other value other than unconfigured should be very carefully evaluated regardless of the fix. Provided the following conditions are met: 1. The Content Security Policy: 1. Has been disabled or modified from the entirely safe default value; and 2. Has been completely disabled by the Administrator by omitting the header explicitly at the proxy (worst practice); or 3. Has been effectively disabled by modifying script-src allowing unsafe inline scripts rather than using hashes AND effectively disabled by modifying connect-src allowing connections to arbitrary websites. 2. Authelia is being hosted on a domain that has other applications that can write to the cookie for the Authelia domain. 3. One of the other applications noted in 2 has an vulnerability that can be exploited…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gmfg-3v4q-9qr4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33525 Advisory: Authelia: Improper Neutralization of Input During Web Page Generation Leads to Potential Cross-site Scripting IDs: CVE-2026-33525, GHSA-gmfg-3v4q-9qr4 Record: https://patchnext.com/advisories/cve-2026-33525 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 0.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/authelia/authelia/v4 4.39.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/authelia/authelia/v4: affected >= 4.39.15, <= 4.39.15; fixed in 4.39.16 ## Suggested inspection (read-only) - Go github.com/authelia/authelia/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/authelia/authelia/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gmfg-3v4q-9qr4 (GitHub-reviewed advisory GHSA-gmfg-3v4q-9qr4 lists affected ranges: Go github.com/authelia/authelia/v4 >=4.39.15 <=4.39.15) Commands are suggestions: review each one before running it.
Loading voting…