Ory Oathkeeper has an authentication bypass by cache key confusion
CVE-2026-33496GHSA-4mq7-pvjg-xp2r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ory/oathkeeper 0.40.10-0.20260320084801-198a2bc82a99), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.40.10-0.20260320084801-198a2bc82a99
- Fixed in
- 0.40.10-0.20260320084801-198a2bc82a99
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mq7-pvjg-xp2r lists affected ranges: Go github.com/ory/oathkeeper >=0 <0.40.10-0.20260320084801-198a2bc82a99
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-33496: 0.38% estimated exploitation activity in the next 30 days; percentile 32.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Ory Oathkeeper is vulnerable to authentication bypass due to cache key confusion. The oauth2introspection authenticator cache does not distinguish tokens that were validated with different introspection URLs. An attacker can therefore legitimately use a token to prime the cache, and subsequently use the same token for rules that use a different introspection server. Preconditions Ory Oathkeeper has to be configured with multiple oauth2introspection authenticator servers, each accepting different tokens. The authenticators also must be configured to use caching. An attacker has to have a way to gain a valid token for one of the configured introspection servers. Mitigation Ory Oathkeeper now includes the introspection server URL in the cache key, preventing confusion of tokens. Update to the patched version of Ory Oathkeeper. If that is not immediately possible, disable caching for oauth2introspection authenticators.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4mq7-pvjg-xp2r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-33496 Advisory: Ory Oathkeeper has an authentication bypass by cache key confusion IDs: CVE-2026-33496, GHSA-4mq7-pvjg-xp2r Record: https://patchnext.com/advisories/cve-2026-33496 (revision 1, source checked 26 Oct 2026, 15:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/ory/oathkeeper 0.40.10-0.20260320084801-198a2bc82a99. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/ory/oathkeeper: affected < 0.40.10-0.20260320084801-198a2bc82a99; fixed in 0.40.10-0.20260320084801-198a2bc82a99 ## Suggested inspection (read-only) - Go github.com/ory/oathkeeper: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/ory/oathkeeper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4mq7-pvjg-xp2r (GitHub-reviewed advisory GHSA-4mq7-pvjg-xp2r lists affected ranges: Go github.com/ory/oathkeeper >=0 <0.40.10-0.20260320084801-198a2bc82a99) Commands are suggestions: review each one before running it.
Loading voting…