Skip to content

← Actionable
Critical, CVSS 10.0

Ory Oathkeeper has a path traversal authorization bypass

CVE-2026-33494GHSA-p224-6x5r-fjpm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ory/oathkeeper 0.40.10-0.20260320084758-8e0002140491), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-33494: 0.53% estimated exploitation activity in the next 30 days; percentile 44.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Ory Oathkeeper is vulnerable to an authorization bypass via HTTP path traversal. An attacker can craft a URL containing path traversal sequences (e.g. /public/../admin/secrets) that resolves to a protected path after normalization, but is matched against a permissive rule because the raw, un-normalized path is used during rule evaluation. Preconditions Ory Oathkeeper rules are typically configured with patterns like: Without path normalization, a request to /public/../admin/secrets is matched against the raw path /public/../admin/secrets. This matches the /public/<. rule, bypassing the authentication required for /admin/secrets. After Ory Oathkeeper permits the request, the upstream server normalizes the path and serves the protected /admin/secrets resource. Mitigation Going forward, Ory Oathkeeper normalizes the request path before performing rule matching and before forwarding. The path /public/../admin/secrets is normalized to /admin/secrets, which correctly matches…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p224-6x5r-fjpm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-33494

Advisory: Ory Oathkeeper has a path traversal authorization bypass
IDs: CVE-2026-33494, GHSA-p224-6x5r-fjpm
Record: https://patchnext.com/advisories/cve-2026-33494 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ory/oathkeeper 0.40.10-0.20260320084758-8e0002140491. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ory/oathkeeper: affected < 0.40.10-0.20260320084758-8e0002140491; fixed in 0.40.10-0.20260320084758-8e0002140491

## Suggested inspection (read-only)
- Go github.com/ory/oathkeeper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ory/oathkeeper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p224-6x5r-fjpm (GitHub-reviewed advisory GHSA-p224-6x5r-fjpm lists affected ranges: Go github.com/ory/oathkeeper >=0 <0.40.10-0.20260320084758-8e0002140491)

Commands are suggestions: review each one before running it.

Loading voting…